CVE-2023-22730 Improper Input Validation of Clearance sale in cart

Medium 5.3 Published Updated

Attackers can bypass quantity limits in clearance sales by adding duplicate line items via the API, affecting Shopware e-commerce platform users.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-22730?

CVE-2023-22730 is a medium-severity vulnerability in Shopware Shopware, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Shopware is an open source commerce platform based on Symfony Framework and Vue js. In affected versions It was possible to put the same line item multiple times in the cart using the AP. The Cart Validators checked the line item's individuality and the user was able to bypass quantity limits in sales. This problem has been fixed with version 6.4.18.1. Users on major versions 6.1, 6.2, and 6.3 may also obtain this fix via a plugin.

Weakness: CWE-20

Which versions are affected by CVE-2023-22730?

4 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.

PackageAffectedFixed in
shopware/core PackagistAll versions6.4.18.1
shopware/core PackagistAll versions6.4.18.1
shopware/platform PackagistAll versions6.4.18.1
shopware/platform PackagistAll versions6.4.18.1

Products include Shopware Shopware.

How do I fix CVE-2023-22730?

Upgrade shopware/core to 6.4.18.1 or later.

Is CVE-2023-22730 being exploited?

There is no known exploitation of CVE-2023-22730 in the wild and no public exploit code.

All Shopware Shopware vulnerabilities

Sources

Also known as GHSA-8r6h-m72v-38fg.

Is CVE-2023-22730 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free