# CVE-2023-22730: Improper Input Validation of Clearance sale in cart

> Attackers can bypass quantity limits in clearance sales by adding duplicate line items via the API, affecting Shopware e-commerce platform users.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-8r6h-m72v-38fg

## What is CVE-2023-22730?

CVE-2023-22730 is a medium-severity vulnerability in Shopware Shopware, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Shopware is an open source commerce platform based on Symfony Framework and Vue js. In affected versions It was possible to put the same line item multiple times in the cart using the AP. The Cart Validators checked the line item's individuality and the user was able to bypass quantity limits in sales. This problem has been fixed with version 6.4.18.1. Users on major versions 6.1, 6.2, and 6.3 may also obtain this fix via a plugin.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-22730?

4 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/core` | Packagist | All versions | 6.4.18.1 |
| `shopware/core` | Packagist | All versions | 6.4.18.1 |
| `shopware/platform` | Packagist | All versions | 6.4.18.1 |
| `shopware/platform` | Packagist | All versions | 6.4.18.1 |

Products: Shopware Shopware.

## How do I fix CVE-2023-22730?

Upgrade shopware/core to 6.4.18.1 or later.

## Is CVE-2023-22730 being exploited?

There is no known exploitation of CVE-2023-22730 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22730 and fix it if it is affected.

What it is: CVE-2023-22730 is a medium-severity vulnerability in Shopware Shopware, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-22730 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/core (Packagist): affected all versions; fixed in 6.4.18.1
- shopware/core (Packagist): affected all versions; fixed in 6.4.18.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.18.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22730/ (Markdown: https://insights.sbomify.com/CVE-2023-22730/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22730
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22730
- OSV: https://osv.dev/vulnerability/CVE-2023-22730

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22730/
Summaries are generated and may contain mistakes; the official description above is the record.
