# CVE-2023-22731: Improper Control of Generation of Code in Twig rendered views in shopware

> Attackers with Twig access can execute arbitrary PHP code via filters if the Sandbox extension is disabled, requiring an upgrade to Shopware.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-93cw-f5jj-x85w

## What is CVE-2023-22731?

CVE-2023-22731 is a critical code injection vulnerability in Shopware Shopware, published on 17 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Shopware is an open source commerce platform based on Symfony Framework and Vue js. In a Twig environment **without the Sandbox extension**, it is possible to refer to PHP functions in twig filters like `map`, `filter`, `sort`. This allows a template to call any global PHP function and thus execute arbitrary code. The attacker must have access to a Twig environment in order to exploit this vulnerability. This problem has been fixed with 6.4.18.1 with an override of the specified filters until the integration of the Sandbox extension has been finished. Users are advised to upgrade. Users of major versions 6.1, 6.2, and 6.3 may also receive this fix via a plugin.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-22731?

4 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/core` | Packagist | All versions | 6.4.18.1 |
| `shopware/core` | Packagist | All versions | 6.4.18.1 |
| `shopware/platform` | Packagist | All versions | 6.4.18.1 |
| `shopware/platform` | Packagist | All versions | 6.4.18.1 |

Products: Shopware Shopware.

## How do I fix CVE-2023-22731?

Upgrade shopware/core to 6.4.18.1 or later.

## Is CVE-2023-22731 being exploited?

There is no known exploitation of CVE-2023-22731 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)
- [CVE-2026-31889](https://insights.sbomify.com/CVE-2026-31889/): Shopware has a potential take over of app credentials (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22731 and fix it if it is affected.

What it is: CVE-2023-22731 is a critical code injection vulnerability in Shopware Shopware, published on 17 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-22731 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/core (Packagist): affected all versions; fixed in 6.4.18.1
- shopware/core (Packagist): affected all versions; fixed in 6.4.18.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.18.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22731/ (Markdown: https://insights.sbomify.com/CVE-2023-22731/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22731
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22731
- OSV: https://osv.dev/vulnerability/CVE-2023-22731

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22731/
Summaries are generated and may contain mistakes; the official description above is the record.
