# CVE-2023-22733: Improper Output Neutralization in Log Module in shopware

> Attackers with log access can view sent emails, potentially exposing user account data and enabling account takeover in Shopware.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-7cp7-jfp6-jh4f

## What is CVE-2023-22733?

CVE-2023-22733 is a low-severity vulnerability in Shopware Shopware, published on 17 Jan 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Shopware is an open source commerce platform based on Symfony Framework and Vue js. In affected versions the log module would write out all kind of sent mails. An attacker with access to either the local system logs or a centralized logging store may have access to other users accounts. This issue has been addressed in version 6.4.18.1. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. Users unable to upgrade may remove from all users the log module ACL rights or disable logging.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2023-22733?

4 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/core` | Packagist | All versions | 6.4.18.1 |
| `shopware/core` | Packagist | All versions | 6.4.18.1 |
| `shopware/platform` | Packagist | All versions | 6.4.18.1 |
| `shopware/platform` | Packagist | All versions | 6.4.18.1 |

Products: Shopware Shopware.

## How do I fix CVE-2023-22733?

Upgrade shopware/core to 6.4.18.1 or later.

## Is CVE-2023-22733 being exploited?

There is no known exploitation of CVE-2023-22733 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22733 and fix it if it is affected.

What it is: CVE-2023-22733 is a low-severity vulnerability in Shopware Shopware, published on 17 Jan 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-22733 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/core (Packagist): affected all versions; fixed in 6.4.18.1
- shopware/core (Packagist): affected all versions; fixed in 6.4.18.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.18.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22733/ (Markdown: https://insights.sbomify.com/CVE-2023-22733/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22733
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22733
- OSV: https://osv.dev/vulnerability/CVE-2023-22733

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22733/
Summaries are generated and may contain mistakes; the official description above is the record.
