# CVE-2023-22734: Improper Input Newsletter subscription option validation in shopware

> Attackers can bypass newsletter double opt-in validation, leading to inconsistent subscriber data in Shopware e-commerce platforms.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-46h7-vj7x-fxg2

## What is CVE-2023-22734?

CVE-2023-22734 is a medium-severity vulnerability in Shopware Shopware, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Shopware is an open source commerce platform based on Symfony Framework and Vue js. The newsletter double opt-in validation was not checked properly, and it was possible to skip the complete double opt in process. As a result operators may have inconsistencies in their newsletter systems. This problem has been fixed with version 6.4.18.1. Users are advised to upgrade. Users unable to upgrade may find security measures are available via a plugin for major versions 6.1, 6.2, and 6.3. Users may also disable newsletter registration completely.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-22734?

4 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/core` | Packagist | All versions | 6.4.18.1 |
| `shopware/core` | Packagist | All versions | 6.4.18.1 |
| `shopware/platform` | Packagist | All versions | 6.4.18.1 |
| `shopware/platform` | Packagist | All versions | 6.4.18.1 |

Products: Shopware Shopware.

## How do I fix CVE-2023-22734?

Upgrade shopware/core to 6.4.18.1 or later.

## Is CVE-2023-22734 being exploited?

There is no known exploitation of CVE-2023-22734 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22734 and fix it if it is affected.

What it is: CVE-2023-22734 is a medium-severity vulnerability in Shopware Shopware, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-22734 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/core (Packagist): affected all versions; fixed in 6.4.18.1
- shopware/core (Packagist): affected all versions; fixed in 6.4.18.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.18.1
- shopware/platform (Packagist): affected all versions; fixed in 6.4.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22734/ (Markdown: https://insights.sbomify.com/CVE-2023-22734/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22734
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22734
- OSV: https://osv.dev/vulnerability/CVE-2023-22734

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22734/
Summaries are generated and may contain mistakes; the official description above is the record.
