CVE-2023-22739 Discourse subject to Allocation of Resources Without Limits or Throttling

Medium 6.5 Published Updated

A malicious user can create arbitrarily large drafts in Discourse, causing resource exhaustion and degrading instance performance.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-22739?

CVE-2023-22739 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 26 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open source platform for community discussion. Versions prior to 3.0.1 (stable), 3.1.0.beta2 (beta), and 3.1.0.beta2 (tests-passed) are subject to Allocation of Resources Without Limits or Throttling. As there is no limit on data contained in a draft, a malicious user can create an arbitrarily large draft, forcing the instance to a crawl. This issue is patched in versions 3.0.1 (stable), 3.1.0.beta2 (beta), and 3.1.0.beta2 (tests-passed). There are no workarounds.

Weakness: CWE-770

Which versions are affected by CVE-2023-22739?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.0.1

Products include Discourse Discourse.

How do I fix CVE-2023-22739?

Upgrade discourse to 3.0.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-22739 being exploited?

There is no known exploitation of CVE-2023-22739 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2023-22739, GHSA-rqgr-g6v7-jcfc.

Is CVE-2023-22739 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free