# CVE-2023-22740: Discourse vulnerable to Allocation of Resources Without Limits via Chat drafts

> Attackers can cause server denial of service by creating unlimited-length chat drafts or loading excessive drafts, requiring an upgrade to Discourse.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** BIT-discourse-2023-22740, GHSA-pwj4-rf62-p224

## What is CVE-2023-22740?

CVE-2023-22740 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 27 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open source platform for community discussion. Versions prior to 3.1.0.beta1 (beta) (tests-passed) are vulnerable to  Allocation of Resources Without Limits. Users can create chat drafts of an unlimited length, which can cause a denial of service by generating an excessive load on the server. Additionally, an unlimited number of drafts were loaded when loading the user. This issue has been patched in version 2.1.0.beta1 (beta) and (tests-passed). Users should upgrade to the latest version where a limit has been introduced. There are no workarounds available.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-22740?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.0.1 |

Products: Discourse Discourse.

## How do I fix CVE-2023-22740?

Upgrade discourse to 3.0.1 or later.

## Is CVE-2023-22740 being exploited?

There is no known exploitation of CVE-2023-22740 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22740 and fix it if it is affected.

What it is: CVE-2023-22740 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 27 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-22740 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22740/ (Markdown: https://insights.sbomify.com/CVE-2023-22740/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22740
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22740
- OSV: https://osv.dev/vulnerability/CVE-2023-22740

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22740/
Summaries are generated and may contain mistakes; the official description above is the record.
