CVE-2023-2279 Cross-site request forgery in WP Directory Kit
Unauthenticated attackers can trick administrators into modifying or deleting plugin settings and content via CSRF.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2023-2279?
CVE-2023-2279 is a medium-severity vulnerability in wpdirectorykit WP Directory Kit, published on 31 Aug 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The WP Directory Kit plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.2.1. This is due to missing or incorrect nonce validation on the 'admin_page_display' function. This makes it possible for unauthenticated attackers to delete or change plugin settings, import demo data, modify or delete Directory Kit related posts and terms via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Partial patches were made avilable in versions 1.2.0 and 1.2.1 but the issue was not fully patched until 1.2.2
Weakness: CWE-352
Which versions are affected by CVE-2023-2279?
It affects 1 product.
Products include Wpdirectorykit Wp Directory Kit.
How do I fix CVE-2023-2279?
No fix has been published for CVE-2023-2279 yet. Limit exposure of the affected software until one is available.
Is CVE-2023-2279 being exploited?
There is no known exploitation of CVE-2023-2279 in the wild and no public exploit code.
Other vulnerabilities in wpdirectorykit WP Directory Kit
- CVE-2025-13390 WP Directory Kit <= 1.4.4 - Authentication Bypass to Privilege Escalation via Account Takeover
- CVE-2023-2278 WP Directory Kit <= 1.1.9 - Unauthenticated Local File Inclusion via wdk_public_action
- CVE-2024-3217 WP Directory Kit <= 1.3.0 - Authenticated (Subscriber+) SQL Injection
- CVE-2024-37487 WordPress WP Directory Kit plugin <= 1.3.5 - Reflected Cross Site Scripting (XSS) vulnerability
- CVE-2024-29774 WordPress WP Directory Kit plugin <= 1.2.9 - Reflected Cross Site Scripting (XSS) vulnerability
Sources
Also known as GHSA-v93c-v766-hw94.