CVE-2023-22792 ReDoS based DoS vulnerability in Action Dispatch

High 7.5 Published Updated

Attackers can cause denial of service in Ruby on Rails applications by sending crafted cookies and headers that trigger catastrophic regex backtracking.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-22792?

CVE-2023-22792 is a high-severity denial of service vulnerability in Rubyonrails Rails, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A regular expression based DoS vulnerability in Action Dispatch <6.0.6.1,< 6.1.7.1, and <7.0.4.1. Specially crafted cookies, in combination with a specially crafted X_FORWARDED_HOST header can cause the regular expression engine to enter a state of catastrophic backtracking. This can cause the process to use large amounts of CPU and memory, leading to a possible DoS vulnerability All users running an affected release should either upgrade or use one of the workarounds immediately.

Weakness: CWE-1333, CWE-400

Which versions are affected by CVE-2023-22792?

6 open source packages ship an affected version, including actionpack. It affects 1 product.

PackageAffectedFixed in
actionpack RubyGemsFrom 3.0.05.2.8.15
actionpack RubyGemsFrom 3.0.05.2.8.15
actionpack RubyGemsFrom 6.0.06.1.7.1
actionpack RubyGemsFrom 6.0.06.1.7.1
actionpack RubyGemsFrom 7.0.07.0.4.1
actionpack RubyGemsFrom 7.0.07.0.4.1

Products include Rubyonrails Rails.

How do I fix CVE-2023-22792?

Upgrade actionpack to a fixed version for your release line: 5.2.8.15, 6.1.7.1 or 7.0.4.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-22792 being exploited?

There is no known exploitation of CVE-2023-22792 in the wild and no public exploit code.

All Rubyonrails Rails vulnerabilities

Sources

Also known as DEBIAN-CVE-2023-22792, GHSA-p84v-45xj-wwqj, UBUNTU-CVE-2023-22792.

Is CVE-2023-22792 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free