# CVE-2023-22792: ReDoS based DoS vulnerability in Action Dispatch

> Attackers can cause denial of service in Ruby on Rails applications by sending crafted cookies and headers that trigger catastrophic regex backtracking.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2023
- **Updated:** 24 Mar 2025
- **Also known as:** DEBIAN-CVE-2023-22792, GHSA-p84v-45xj-wwqj, UBUNTU-CVE-2023-22792

## What is CVE-2023-22792?

CVE-2023-22792 is a high-severity denial of service vulnerability in Rubyonrails Rails, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A regular expression based DoS vulnerability in Action Dispatch <6.0.6.1,< 6.1.7.1, and <7.0.4.1. Specially crafted cookies, in combination with a specially crafted X_FORWARDED_HOST header can cause the regular expression engine to enter a state of catastrophic backtracking. This can cause the process to use large amounts of CPU and memory, leading to a possible DoS vulnerability All users running an affected release should either upgrade or use one of the workarounds immediately.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-22792?

6 open source packages ship an affected version, including actionpack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | From 3.0.0 | 5.2.8.15 |
| `actionpack` | RubyGems | From 3.0.0 | 5.2.8.15 |
| `actionpack` | RubyGems | From 6.0.0 | 6.1.7.1 |
| `actionpack` | RubyGems | From 6.0.0 | 6.1.7.1 |
| `actionpack` | RubyGems | From 7.0.0 | 7.0.4.1 |
| `actionpack` | RubyGems | From 7.0.0 | 7.0.4.1 |

Products: Rubyonrails Rails.

## How do I fix CVE-2023-22792?

Upgrade actionpack to a fixed version for your release line: 5.2.8.15, 6.1.7.1 or 7.0.4.1.

## Is CVE-2023-22792 being exploited?

There is no known exploitation of CVE-2023-22792 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22792 and fix it if it is affected.

What it is: CVE-2023-22792 is a high-severity denial of service vulnerability in Rubyonrails Rails, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-22792 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionpack (RubyGems): affected from 3.0.0; fixed in 5.2.8.15
- actionpack (RubyGems): affected from 3.0.0; fixed in 5.2.8.15
- actionpack (RubyGems): affected from 6.0.0; fixed in 6.1.7.1
- actionpack (RubyGems): affected from 6.0.0; fixed in 6.1.7.1
- actionpack (RubyGems): affected from 7.0.0; fixed in 7.0.4.1
- actionpack (RubyGems): affected from 7.0.0; fixed in 7.0.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22792/ (Markdown: https://insights.sbomify.com/CVE-2023-22792/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22792
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22792
- OSV: https://osv.dev/vulnerability/CVE-2023-22792

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22792/
Summaries are generated and may contain mistakes; the official description above is the record.
