# CVE-2023-22795: ReDoS based DoS vulnerability in Action Dispatch

> Attackers can cause denial of service in Ruby on Rails applications via crafted HTTP headers triggering regex backtracking.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2023
- **Updated:** 2 Aug 2024
- **Also known as:** AZL-13562, DEBIAN-CVE-2023-22795, GHSA-8xww-x3g3-6jcv, UBUNTU-CVE-2023-22795

## What is CVE-2023-22795?

CVE-2023-22795 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A regular expression based DoS vulnerability in Action Dispatch <6.1.7.1 and <7.0.4.1 related to the If-None-Match header. A specially crafted HTTP If-None-Match header can cause the regular expression engine to enter a state of catastrophic backtracking, when on a version of Ruby below 3.2.0. This can cause the process to use large amounts of CPU and memory, leading to a possible DoS vulnerability All users running an affected release should either upgrade or use one of the workarounds immediately.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-22795?

4 open source packages ship an affected version, including actionpack. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | From 4.0.0.beta1 | 6.1.7.1 |
| `actionpack` | RubyGems | From 4.0.0.beta1 | 6.1.7.1 |
| `actionpack` | RubyGems | From 7.0.0 | 7.0.4.1 |
| `actionpack` | RubyGems | From 7.0.0 | 7.0.4.1 |

Products: Debian Debian Linux, Rubyonrails Rails.

## How do I fix CVE-2023-22795?

Upgrade actionpack to a fixed version for your release line: 6.1.7.1 or 7.0.4.1.

## Is CVE-2023-22795 being exploited?

There is no known exploitation of CVE-2023-22795 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22795 and fix it if it is affected.

What it is: CVE-2023-22795 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-22795 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionpack (RubyGems): affected from 4.0.0.beta1; fixed in 6.1.7.1
- actionpack (RubyGems): affected from 4.0.0.beta1; fixed in 6.1.7.1
- actionpack (RubyGems): affected from 7.0.0; fixed in 7.0.4.1
- actionpack (RubyGems): affected from 7.0.0; fixed in 7.0.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22795/ (Markdown: https://insights.sbomify.com/CVE-2023-22795/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22795
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22795
- OSV: https://osv.dev/vulnerability/CVE-2023-22795

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22795/
Summaries are generated and may contain mistakes; the official description above is the record.
