# CVE-2023-22796: ReDoS based DoS vulnerability in Active Support's underscore

> Attackers can cause denial of service in Ruby on Rails applications by sending specially crafted strings that trigger catastrophic backtracking in regular expressions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2023
- **Updated:** 27 Nov 2024
- **Also known as:** DEBIAN-CVE-2023-22796, GHSA-j6gc-792m-qgm2, OESA-2023-1130, OESA-2023-1140, OESA-2023-1145, OESA-2023-1154, SUSE-SU-2023:0275-1, SUSE-SU-2023:0612-1, UBUNTU-CVE-2023-22796, openSUSE-SU-2024:12767-1

## What is CVE-2023-22796?

CVE-2023-22796 is a high-severity denial of service vulnerability in https://github.com/rails/rails, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A regular expression based DoS vulnerability in Active Support <6.1.7.1 and <7.0.4.1. A specially crafted string passed to the underscore method can cause the regular expression engine to enter a state of catastrophic backtracking. This can cause the process to use large amounts of CPU and memory, leading to a possible DoS vulnerability.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-22796?

4 open source packages ship an affected version, including activesupport. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activesupport` | RubyGems | All versions | 6.1.7.1 |
| `activesupport` | RubyGems | All versions | 6.1.7.1 |
| `activesupport` | RubyGems | From 7.0.0 | 7.0.4.1 |
| `activesupport` | RubyGems | From 7.0.0 | 7.0.4.1 |
| `rubygem-activesupport-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 5.1.4-150000.3.12.1 |
| `rubygem-activesupport-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 5.1.4-150000.3.12.1 |
| `rubygem-activesupport-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP3 | All versions | 5.1.4-150000.3.12.1 |
| `rubygem-activesupport-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP4 | All versions | 5.1.4-150000.3.12.1 |
| `rubygem-activesupport-4_2` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 4.2.9-7.15.1 |
| `rubygem-activesupport-4_2` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 4.2.9-7.15.1 |
| `rubygem-activesupport-5_1` | openSUSE:Leap 15.4 | All versions | 5.1.4-150000.3.12.1 |
| `rubygem-activesupport-7.0` | openSUSE:Tumbleweed | All versions | 7.0.4.1-1.1 |

Products: Activesupport Project Activesupport.

## How do I fix CVE-2023-22796?

Upgrade activesupport to a fixed version for your release line: 6.1.7.1 or 7.0.4.1.

## Is CVE-2023-22796 being exploited?

There is no known exploitation of CVE-2023-22796 in the wild and no public exploit code.

## Other vulnerabilities in https://github.com/rails/rails

- [CVE-2018-3779](https://insights.sbomify.com/CVE-2018-3779/): active-support impersonates 'activesupport' gem (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22796 and fix it if it is affected.

What it is: CVE-2023-22796 is a high-severity denial of service vulnerability in https://github.com/rails/rails, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-22796 in the wild and no public exploit code.

Affected packages and fixed versions:
- activesupport (RubyGems): affected all versions; fixed in 6.1.7.1
- activesupport (RubyGems): affected all versions; fixed in 6.1.7.1
- activesupport (RubyGems): affected from 7.0.0; fixed in 7.0.4.1
- activesupport (RubyGems): affected from 7.0.0; fixed in 7.0.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22796/ (Markdown: https://insights.sbomify.com/CVE-2023-22796/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22796
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22796
- OSV: https://osv.dev/vulnerability/CVE-2023-22796

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22796/
Summaries are generated and may contain mistakes; the official description above is the record.
