CVE-2023-22799 ReDoS based DoS vulnerability in GlobalID
An attacker can cause a denial of service in applications using the GlobalID library by supplying crafted input that triggers excessive regular expression processing time.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-22799?
CVE-2023-22799 is a high-severity denial of service vulnerability in https://github.com/rails/globalid, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A ReDoS based DoS vulnerability in the GlobalID <1.0.1 which could allow an attacker supplying a carefully crafted input can cause the regular expression engine to take an unexpected amount of time. All users running an affected release should either upgrade or use one of the workarounds immediately.
Which versions are affected by CVE-2023-22799?
2 open source packages ship an affected version, including globalid. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
globalid RubyGems | From 0.2.1 | 1.0.1 |
globalid RubyGems | From 0.2.1 | 1.0.1 |
Linux distribution packages (10)
rubygem-globalid SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 0.4.1-150000.3.3.1 |
rubygem-globalid SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 0.4.1-150000.3.3.1 |
rubygem-globalid SUSE:Linux Enterprise High Availability Extension 15 SP3 | All versions | 0.4.1-150000.3.3.1 |
rubygem-globalid SUSE:Linux Enterprise High Availability Extension 15 SP4 | All versions | 0.4.1-150000.3.3.1 |
rubygem-globalid openSUSE:Leap 15.4 | All versions | 0.4.1-150000.3.3.1 |
ruby3.2-rubygem-globalid openSUSE:Tumbleweed | All versions | 1.1.0-1.3 |
rubygem-globalid openSUSE:Tumbleweed | All versions | 1.1.0-1.1 |
rubygem-globalid openSUSE:Tumbleweed | All versions | 1.2.1-1.5 |
rubygem-globalid openSUSE:Tumbleweed | All versions | 1.2.1-1.7 |
rubygem-globalid openSUSE:Tumbleweed | All versions | 1.2.1-1.9 |
Products include Rubyonrails Globalid.
How do I fix CVE-2023-22799?
Upgrade globalid to 1.0.1 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-22799 being exploited?
There is no known exploitation of CVE-2023-22799 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2023-22799, GHSA-23c2-gwp5-pxw9, OESA-2023-1100, OESA-2023-1101, OESA-2023-1102, OESA-2023-1112 and 7 more.