# CVE-2023-22799: ReDoS based DoS vulnerability in GlobalID

> An attacker can cause a denial of service in applications using the GlobalID library by supplying crafted input that triggers excessive regular expression processing time.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2023
- **Updated:** 2 Aug 2024
- **Also known as:** DEBIAN-CVE-2023-22799, GHSA-23c2-gwp5-pxw9, OESA-2023-1100, OESA-2023-1101, OESA-2023-1102, OESA-2023-1112, SUSE-SU-2023:0328-1, UBUNTU-CVE-2023-22799, openSUSE-SU-2024:12648-1, openSUSE-SU-2024:13156-1, openSUSE-SU-2024:14168-1, openSUSE-SU-2025:15116-1, openSUSE-SU-2026:10347-1

## What is CVE-2023-22799?

CVE-2023-22799 is a high-severity denial of service vulnerability in https://github.com/rails/globalid, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A ReDoS based DoS vulnerability in the GlobalID <1.0.1 which could allow an attacker supplying a carefully crafted input can cause the regular expression engine to take an unexpected amount of time. All users running an affected release should either upgrade or use one of the workarounds immediately.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-22799?

2 open source packages ship an affected version, including globalid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `globalid` | RubyGems | From 0.2.1 | 1.0.1 |
| `globalid` | RubyGems | From 0.2.1 | 1.0.1 |
| `rubygem-globalid` | SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 0.4.1-150000.3.3.1 |
| `rubygem-globalid` | SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 0.4.1-150000.3.3.1 |
| `rubygem-globalid` | SUSE:Linux Enterprise High Availability Extension 15 SP3 | All versions | 0.4.1-150000.3.3.1 |
| `rubygem-globalid` | SUSE:Linux Enterprise High Availability Extension 15 SP4 | All versions | 0.4.1-150000.3.3.1 |
| `rubygem-globalid` | openSUSE:Leap 15.4 | All versions | 0.4.1-150000.3.3.1 |
| `ruby3.2-rubygem-globalid` | openSUSE:Tumbleweed | All versions | 1.1.0-1.3 |
| `rubygem-globalid` | openSUSE:Tumbleweed | All versions | 1.1.0-1.1 |
| `rubygem-globalid` | openSUSE:Tumbleweed | All versions | 1.2.1-1.5 |
| `rubygem-globalid` | openSUSE:Tumbleweed | All versions | 1.2.1-1.7 |
| `rubygem-globalid` | openSUSE:Tumbleweed | All versions | 1.2.1-1.9 |

Products: Rubyonrails Globalid.

## How do I fix CVE-2023-22799?

Upgrade globalid to 1.0.1 or later.

## Is CVE-2023-22799 being exploited?

There is no known exploitation of CVE-2023-22799 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22799 and fix it if it is affected.

What it is: CVE-2023-22799 is a high-severity denial of service vulnerability in https://github.com/rails/globalid, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-22799 in the wild and no public exploit code.

Affected packages and fixed versions:
- globalid (RubyGems): affected from 0.2.1; fixed in 1.0.1
- globalid (RubyGems): affected from 0.2.1; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22799/ (Markdown: https://insights.sbomify.com/CVE-2023-22799/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22799
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22799
- OSV: https://osv.dev/vulnerability/CVE-2023-22799

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22799/
Summaries are generated and may contain mistakes; the official description above is the record.
