# CVE-2023-22886: Apache Airflow JDBC Provider: RCE Vulnerability

> Attackers can execute arbitrary code and gain server permissions via unrestricted JDBC connection URLs in Apache Airflow.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jun 2023
- **Updated:** 7 Oct 2024
- **Also known as:** GHSA-mm87-c3x2-6f89, PYSEC-2026-1149

## What is CVE-2023-22886?

CVE-2023-22886 is a high-severity code injection vulnerability in Apache Airflow JDBC Provider, published on 29 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow JDBC Provider.
Airflow JDBC Provider Connection’s [Connection URL] parameters had no
restrictions, which made it possible to implement RCE attacks via
different type JDBC drivers, obtain airflow server permission.
This issue affects Apache Airflow JDBC Provider: before 4.0.0.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-22886?

3 open source packages ship an affected version, including apache-airflow-providers-jdbc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-jdbc` | PyPI | All versions | 4.0.0 |
| `apache-airflow-providers-jdbc` | PyPI | All versions | 4.0.0 |
| `apache-airflow-providers-jdbc` | PyPI | All versions | 4.0.0 |

Products: Apache Apache-Airflow-Providers-Jdbc.

## How do I fix CVE-2023-22886?

Upgrade apache-airflow-providers-jdbc to 4.0.0 or later.

## Is CVE-2023-22886 being exploited?

There is no known exploitation of CVE-2023-22886 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22886 and fix it if it is affected.

What it is: CVE-2023-22886 is a high-severity code injection vulnerability in Apache Airflow JDBC Provider, published on 29 Jun 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-22886 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-jdbc (PyPI): affected all versions; fixed in 4.0.0
- apache-airflow-providers-jdbc (PyPI): affected all versions; fixed in 4.0.0
- apache-airflow-providers-jdbc (PyPI): affected all versions; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22886/ (Markdown: https://insights.sbomify.com/CVE-2023-22886/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22886
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22886
- OSV: https://osv.dev/vulnerability/CVE-2023-22886

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22886/
Summaries are generated and may contain mistakes; the official description above is the record.
