# CVE-2023-22893: Strapi does not verify the access or ID tokens issued during the OAuth flow

> Attackers can bypass authentication and impersonate users by forging ID tokens when using the AWS Cognito login provider in Strapi.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Apr 2023
- **Updated:** 7 Nov 2025
- **Also known as:** GHSA-583x-23h9-f5w7

## What is CVE-2023-22893?

CVE-2023-22893 is a high-severity authentication bypass vulnerability in n/a, published on 19 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Strapi through 4.5.5 does not verify the access or ID tokens issued during the OAuth flow when the AWS Cognito login provider is used for authentication. A remote attacker could forge an ID token that is signed using the 'None' type algorithm to bypass authentication and impersonate any user that use AWS Cognito for authentication.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2023-22893?

2 open source packages ship an affected version, including @strapi/plugin-users-permissions. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@strapi/plugin-users-permissions` | npm | From 3.2.1 | 4.6.0 |
| `@strapi/plugin-users-permissions` | npm | From 3.2.1 | 4.6.0 |

Products: Strapi Strapi.

## How do I fix CVE-2023-22893?

Upgrade @strapi/plugin-users-permissions to 4.6.0 or later.

## Is CVE-2023-22893 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22893 exists.

Public exploit code:

- Strapi Versions <=4.5.6 - Authentication Bypass (nuclei): http/cves/2023/CVE-2023-22893.yaml

## Other vulnerabilities in n/a

- [CVE-2023-22894](https://insights.sbomify.com/CVE-2023-22894/): Strapi Cleartext Storage of Sensitive Information (high 7.2, exploited in the wild)
- [CVE-2023-22621](https://insights.sbomify.com/CVE-2023-22621/): Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin (critical 10.0)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2020-27664](https://insights.sbomify.com/CVE-2020-27664/): Authorization bypass in Strapi (critical 9.8)
- [CVE-2019-18818](https://insights.sbomify.com/CVE-2019-18818/): Strapi allows unauthenticated attacker to reset admin password without valid reset token (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22893 and fix it if it is affected.

What it is: CVE-2023-22893 is a high-severity authentication bypass vulnerability in n/a, published on 19 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22893 exists.

Affected packages and fixed versions:
- @strapi/plugin-users-permissions (npm): affected from 3.2.1; fixed in 4.6.0
- @strapi/plugin-users-permissions (npm): affected from 3.2.1; fixed in 4.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22893/ (Markdown: https://insights.sbomify.com/CVE-2023-22893/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22893
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22893
- OSV: https://osv.dev/vulnerability/CVE-2023-22893

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22893/
Summaries are generated and may contain mistakes; the official description above is the record.
