# CVE-2023-22894: Strapi Cleartext Storage of Sensitive Information

> Authenticated attackers can exploit query filters to discover sensitive user details, including password hashes and reset tokens, via the admin panel.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 8 Oct 2026 (CISA KEV)
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Apr 2023
- **Updated:** 9 Oct 2026
- **Also known as:** GHSA-jjqf-j4w7-92w8

## What is CVE-2023-22894?

CVE-2023-22894 is a high-severity vulnerability in n/a, published on 19 Apr 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Strapi through 4.5.5 allows attackers (with access to the admin panel) to discover sensitive user details by exploiting the query filter. The attacker can filter users by columns that contain sensitive information and infer a value from API responses. If the attacker has super admin access, then this can be exploited to discover the password hash and password reset token of all users. If the attacker has admin panel access to an account with permission to access the username and email of API users with a lower privileged role (e.g., Editor or Author), then this can be exploited to discover sensitive information for all API users but not other admin accounts.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2023-22894?

2 open source packages ship an affected version, including @strapi/strapi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@strapi/strapi` | npm | From 3.2.1 | 4.8.0 |
| `@strapi/strapi` | npm | From 3.2.1 | 4.8.0 |

Products: Strapi Strapi.

## How do I fix CVE-2023-22894?

Upgrade @strapi/strapi to 4.8.0 or later. US federal agencies must fix it by 11 Oct 2026.

## Is CVE-2023-22894 being exploited?

Yes. Attackers have exploited CVE-2023-22894 in the wild since at least 8 Oct 2026.

Public exploit code:

- CVE-2023-22894 (github_poc): https://github.com/Saboor-Hakimi/CVE-2023-22894
- https://github.com/maxntv/CVE-2023-22894-PoC (github_poc): https://github.com/maxntv/CVE-2023-22894-PoC

## Other vulnerabilities in n/a

- [CVE-2023-22621](https://insights.sbomify.com/CVE-2023-22621/): Strapi plugins vulnerable to Server-Side Template Injection and Remote Code Execution in the Users-Permissions Plugin (critical 10.0)
- [CVE-2022-27263](https://insights.sbomify.com/CVE-2022-27263/): Unrestricted Upload of File with Dangerous Type in Strapi (critical 9.8)
- [CVE-2020-27664](https://insights.sbomify.com/CVE-2020-27664/): Authorization bypass in Strapi (critical 9.8)
- [CVE-2019-18818](https://insights.sbomify.com/CVE-2019-18818/): Strapi allows unauthenticated attacker to reset admin password without valid reset token (critical 9.8)
- [CVE-2026-22599](https://insights.sbomify.com/CVE-2026-22599/): Strapi Vulnerable to SQL Injection in Content Type Builder (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22894 and fix it if it is affected.

What it is: CVE-2023-22894 is a high-severity vulnerability in n/a, published on 19 Apr 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2023-22894 in the wild since at least 8 Oct 2026.

Affected packages and fixed versions:
- @strapi/strapi (npm): affected from 3.2.1; fixed in 4.8.0
- @strapi/strapi (npm): affected from 3.2.1; fixed in 4.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22894/ (Markdown: https://insights.sbomify.com/CVE-2023-22894/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22894
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22894
- OSV: https://osv.dev/vulnerability/CVE-2023-22894

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22894/
Summaries are generated and may contain mistakes; the official description above is the record.
