# CVE-2023-22895: bzip2 allows attackers to cause a denial of service via a large file that triggers an integer overflow

> Attackers can cause denial of service in applications using the Rust bzip2 crate by providing a large file that triggers an integer overflow.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jan 2023
- **Updated:** 7 Apr 2025
- **Also known as:** DEBIAN-CVE-2023-22895, GHSA-96jv-r488-c2rj, RUSTSEC-2023-0004, UBUNTU-CVE-2023-22895, openSUSE-SU-2024:12610-1, openSUSE-SU-2024:12614-1, openSUSE-SU-2024:12616-1, openSUSE-SU-2025:15094-1

## What is CVE-2023-22895?

CVE-2023-22895 is a high-severity vulnerability in n/a, published on 10 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The bzip2 crate before 0.4.4 for Rust allow attackers to cause a denial of service via a large file that triggers an integer overflow in mem.rs. NOTE: this is unrelated to the https://crates.io/crates/bzip2-rs product.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2023-22895?

3 open source packages ship an affected version, including bzip2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bzip2` | crates.io | All versions | 0.4.4 |
| `bzip2` | crates.io | All versions | 0.4.4 |
| `bzip2` | crates.io | From 0.0.0-0 | 0.4.4 |
| `python-cramjam` | openSUSE:Tumbleweed | All versions | 2.9.1-1.3 |
| `rage-encryption` | openSUSE:Tumbleweed | All versions | 0.9.0+0-4.1 |
| `wasm-pack` | openSUSE:Tumbleweed | All versions | 0.10.3~0-2.1 |

Products: Bzip2 Project Bzip2.

## How do I fix CVE-2023-22895?

Upgrade bzip2 to 0.4.4 or later.

## Is CVE-2023-22895 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22895 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22895 and fix it if it is affected.

What it is: CVE-2023-22895 is a high-severity vulnerability in n/a, published on 10 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22895 exists.

Affected packages and fixed versions:
- bzip2 (crates.io): affected all versions; fixed in 0.4.4
- bzip2 (crates.io): affected all versions; fixed in 0.4.4
- bzip2 (crates.io): affected from 0.0.0-0; fixed in 0.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22895/ (Markdown: https://insights.sbomify.com/CVE-2023-22895/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22895
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22895
- OSV: https://osv.dev/vulnerability/CVE-2023-22895

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22895/
Summaries are generated and may contain mistakes; the official description above is the record.
