CVE-2023-22909 Denial of service in n/a
Remote attackers can cause denial of service in MediaWiki via slow database queries in SpecialMobileHistory.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-22909?
CVE-2023-22909 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 10 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in MediaWiki before 1.35.9, 1.36.x through 1.38.x before 1.38.5, and 1.39.x before 1.39.1. SpecialMobileHistory allows remote attackers to cause a denial of service because database queries are slow.
Which versions are affected by CVE-2023-22909?
1 open source package ship an affected version, including mediawiki. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.35.9, 1.38.5, 1.39.1 |
Products include Fedoraproject Fedora, Mediawiki Mediawiki.
How do I fix CVE-2023-22909?
Upgrade mediawiki to a fixed version for your release line: 1.35.9, 1.38.5 or 1.39.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-22909 being exploited?
There is no known exploitation of CVE-2023-22909 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as BIT-mediawiki-2023-22909, GHSA-4wpp-22r3-jr8g, UBUNTU-CVE-2023-22909.