CVE-2023-22910 Cross-site scripting in n/a

Medium 5.4 Published Updated

Cross-site scripting in MediaWiki Wikibase allows JavaScript execution by staff or admin users without edit capabilities.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-22910?

CVE-2023-22910 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 20 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue was discovered in MediaWiki before 1.35.9, 1.36.x through 1.38.x before 1.38.5, and 1.39.x before 1.39.1. There is XSS in Wikibase date formatting via wikibase-time-precision-* fields. This allows JavaScript execution by staff/admin users who do not intentionally have the editsitejs capability.

Weakness: CWE-79

Which versions are affected by CVE-2023-22910?

1 open source package ship an affected version, including mediawiki. It affects 1 product.

PackageAffectedFixed in
mediawiki BitnamiAll versions1.35.9, 1.38.5, 1.39.1

Products include Mediawiki Mediawiki.

How do I fix CVE-2023-22910?

Upgrade mediawiki to a fixed version for your release line: 1.35.9, 1.38.5 or 1.39.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2023-22910 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-22910 exists.

All Mediawiki Mediawiki vulnerabilities

Sources

Also known as BIT-mediawiki-2023-22910, GHSA-mxwv-hm79-63w8.

Is CVE-2023-22910 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free