CVE-2023-22911 Cross-site scripting in n/a
Cross-site scripting vulnerability in MediaWiki allows attackers to execute arbitrary scripts via widget replacement in HTML attributes.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-22911?
CVE-2023-22911 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 10 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue was discovered in MediaWiki before 1.35.9, 1.36.x through 1.38.x before 1.38.5, and 1.39.x before 1.39.1. E-Widgets does widget replacement in HTML attributes, which can lead to XSS, because widget authors often do not expect that their widget is executed in an HTML attribute context.
Weakness: CWE-79
Which versions are affected by CVE-2023-22911?
1 open source package ship an affected version, including mediawiki. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.35.9, 1.38.5, 1.39.1 |
Products include Fedoraproject Fedora, Mediawiki Mediawiki.
How do I fix CVE-2023-22911?
Upgrade mediawiki to a fixed version for your release line: 1.35.9, 1.38.5 or 1.39.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-22911 being exploited?
There is no known exploitation of CVE-2023-22911 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as BIT-mediawiki-2023-22911, GHSA-6fwq-c2cr-jg74, UBUNTU-CVE-2023-22911.