# CVE-2023-22911: Cross-site scripting in n/a

> Cross-site scripting vulnerability in MediaWiki allows attackers to execute arbitrary scripts via widget replacement in HTML attributes.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jan 2023
- **Updated:** 7 Apr 2025
- **Also known as:** BIT-mediawiki-2023-22911, GHSA-6fwq-c2cr-jg74, UBUNTU-CVE-2023-22911

## What is CVE-2023-22911?

CVE-2023-22911 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 10 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in MediaWiki before 1.35.9, 1.36.x through 1.38.x before 1.38.5, and 1.39.x before 1.39.1. E-Widgets does widget replacement in HTML attributes, which can lead to XSS, because widget authors often do not expect that their widget is executed in an HTML attribute context.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-22911?

1 open source package ship an affected version, including mediawiki. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.35.9, 1.38.5, 1.39.1 |

Products: Fedoraproject Fedora, Mediawiki Mediawiki.

## How do I fix CVE-2023-22911?

Upgrade mediawiki to a fixed version for your release line: 1.35.9, 1.38.5 or 1.39.1.

## Is CVE-2023-22911 being exploited?

There is no known exploitation of CVE-2023-22911 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22911 and fix it if it is affected.

What it is: CVE-2023-22911 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 10 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-22911 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.35.9, 1.38.5, 1.39.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22911/ (Markdown: https://insights.sbomify.com/CVE-2023-22911/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22911
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22911
- OSV: https://osv.dev/vulnerability/CVE-2023-22911

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22911/
Summaries are generated and may contain mistakes; the official description above is the record.
