# CVE-2023-22946: Apache Spark proxy-user privilege escalation from malicious configuration class

> Attackers can escalate privileges and execute code as the submitting user by providing malicious configuration classes in Apache Spark applications using proxy-user.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Apr 2023
- **Updated:** 21 Oct 2024
- **Also known as:** BIT-spark-2023-22946, GHSA-329j-jfvr-rhr6, PYSEC-2023-44

## What is CVE-2023-22946?

CVE-2023-22946 is a medium-severity vulnerability in Apache Spark, published on 17 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Apache Spark versions prior to 3.4.0, applications using spark-submit can specify a 'proxy-user' to run as, limiting privileges. The application can execute code with the privileges of the submitting user, however, by providing malicious configuration-related classes on the classpath. This affects architectures relying on proxy-user, for example those using Apache Livy to manage submitted applications.

Update to Apache Spark 3.4.0 or later, and ensure that 
spark.submit.proxyUser.allowCustomClasspathInClusterMode is set to its 
default of "false", and is not overridden by submitted applications.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2023-22946?

8 open source packages ship an affected version, including org.apache.spark:spark-core_2.12, spark and org.apache.spark:spark-core_2.13. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.spark:spark-core_2.12` | Maven | All versions | 3.3.3 |
| `org.apache.spark:spark-core_2.12` | Maven | All versions | 3.3.3 |
| `spark` | Bitnami | All versions | 3.4.0 |
| `org.apache.spark:spark-core_2.13` | Maven | All versions | 3.3.3 |
| `org.apache.spark:spark-core_2.13` | Maven | All versions | 3.3.3 |
| `pyspark` | PyPI | All versions | 3.3.2 |
| `pyspark` | PyPI | All versions | 3.3.2 |
| `pyspark` | PyPI | All versions | 3.4.0 |

Products: Apache Spark.

## How do I fix CVE-2023-22946?

Upgrade org.apache.spark:spark-core_2.12 to 3.3.3 or later.

## Is CVE-2023-22946 being exploited?

There is no known exploitation of CVE-2023-22946 in the wild and no public exploit code.

## Other vulnerabilities in Apache Spark

- [CVE-2022-33891](https://insights.sbomify.com/CVE-2022-33891/): Apache Spark Command Injection (high 8.8, exploited in the wild)
- [CVE-2020-9480](https://insights.sbomify.com/CVE-2020-9480/): Improper Authentication in Apache Spark (critical 9.8)
- [CVE-2018-17190](https://insights.sbomify.com/CVE-2018-17190/): Remote Code Execution in spark-core (critical 9.8)
- [CVE-2019-20445](https://insights.sbomify.com/CVE-2019-20445/): HTTP Request Smuggling in Netty (critical 9.1)
- [CVE-2025-54920](https://insights.sbomify.com/CVE-2025-54920/): Apache Spark: Spark History Server Code Execution Vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-22946 and fix it if it is affected.

What it is: CVE-2023-22946 is a medium-severity vulnerability in Apache Spark, published on 17 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-22946 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.spark:spark-core_2.12 (Maven): affected all versions; fixed in 3.3.3
- org.apache.spark:spark-core_2.12 (Maven): affected all versions; fixed in 3.3.3
- spark (Bitnami): affected all versions; fixed in 3.4.0
- org.apache.spark:spark-core_2.13 (Maven): affected all versions; fixed in 3.3.3
- org.apache.spark:spark-core_2.13 (Maven): affected all versions; fixed in 3.3.3
- pyspark (PyPI): affected all versions; fixed in 3.3.2
- pyspark (PyPI): affected all versions; fixed in 3.3.2
- pyspark (PyPI): affected all versions; fixed in 3.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-22946/ (Markdown: https://insights.sbomify.com/CVE-2023-22946/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-22946
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-22946
- OSV: https://osv.dev/vulnerability/CVE-2023-22946

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-22946/
Summaries are generated and may contain mistakes; the official description above is the record.
