{"answers":{"affected":"2 open source packages ship an affected version, including personnummer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-22963 in the wild and no public exploit code.","fix":"Upgrade personnummer to 3.0.3 or later.","what":"CVE-2023-22963 is a medium-severity vulnerability in n/a, published on 11 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-22963 and fix it if it is affected.\n\nWhat it is: CVE-2023-22963 is a medium-severity vulnerability in n/a, published on 11 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-22963 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- personnummer (Pub): affected all versions; fixed in 3.0.3\n- personnummer (Pub): affected all versions; fixed in 3.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-22963/ (Markdown: https://insights.sbomify.com/CVE-2023-22963/index.md)","id":"CVE-2023-22963","markdown":"https://insights.sbomify.com/CVE-2023-22963/index.md","name":"CVE-2023-22963","record":{"aliases":["GHSA-4xh4-v2pq-jvhm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["other"],"network_reachable":"yes","non_default_config":false,"product_category":"Dart personnummer library","requires_auth":"none","summary":"A logic error in the Dart personnummer library mishandles specific number formats, potentially leading to incorrect validation results.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"personnummer","vendor":"personnummer"}],"cvss":{"score":5.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The personnummer implementation before 3.0.3 for Dart mishandles numbers in which the last four digits match the ^000[0-9]$ regular expression.","ecosystems":["Pub"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"personnummer/dart vulnerable to Improper Input Validation","id":"CVE-2023-22963","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"other","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Auth bypass in n/a","id":"CVE-2023-22964"},"packages":[{"ecosystem":"Pub","fixed":["3.0.3"],"introduced":["0"],"last_affected":[],"package":"personnummer","purl":null,"source":"GHSA-4xh4-v2pq-jvhm"},{"ecosystem":"Pub","fixed":["3.0.3"],"introduced":["0"],"last_affected":[],"package":"personnummer","purl":"pkg:pub/personnummer","source":"GHSA-4xh4-v2pq-jvhm"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2023-22960"},"products":["n/a"],"published":"2023-01-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-07","vendors":["n/a"]},"summary":"A logic error in the Dart personnummer library mishandles specific number formats, potentially leading to incorrect validation results.","url":"https://insights.sbomify.com/CVE-2023-22963/"}