CVE-2023-2301 Contact Form Builder by vcita <= 4.10.3 - Cross-Site Request Forgery to Stored Cross-Site Scripting
Unauthenticated attackers can trick administrators into modifying plugin settings and injecting malicious JavaScript via forged requests.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2023-2301?
CVE-2023-2301 is a medium-severity vulnerability in eyale-vc Contact Form Builder by vcita, published on 3 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The Contact Form Builder by vcita plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 4.10.3. This is due to missing nonce validation on the ls_parse_vcita_callback function. This makes it possible for unauthenticated attackers to modify the plugin's settings and inject malicious JavaScript via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. While the Cross-Site Scripting issue was patched in version 4.10.1, the plugin is still technically vulnerable to Cross-Site Request Forgery since a capability check but no nonce check was added in 4.10.2.
Weakness: CWE-352
Which versions are affected by CVE-2023-2301?
It affects 1 product.
Products include Vcita Contact Form Builder by Vcita.
How do I fix CVE-2023-2301?
No fix has been published for CVE-2023-2301 yet. Limit exposure of the affected software until one is available.
Is CVE-2023-2301 being exploited?
There is no known exploitation of CVE-2023-2301 in the wild and no public exploit code.
Other vulnerabilities in eyale-vc Contact Form Builder by vcita
Sources
Also known as GHSA-vv4f-mm3r-fgx7.