# CVE-2023-2301: Contact Form Builder by vcita <= 4.10.3 - Cross-Site Request Forgery to Stored Cross-Site Scripting

> Unauthenticated attackers can trick administrators into modifying plugin settings and injecting malicious JavaScript via forged requests.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 3 Jun 2023
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-vv4f-mm3r-fgx7

## What is CVE-2023-2301?

CVE-2023-2301 is a medium-severity vulnerability in eyale-vc Contact Form Builder by vcita, published on 3 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Contact Form Builder by vcita plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 4.10.3. This is due to missing nonce validation on the ls_parse_vcita_callback function. This makes it possible for unauthenticated attackers to modify the plugin's settings and inject malicious JavaScript via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. While the Cross-Site Scripting issue was patched in version 4.10.1, the plugin is still technically vulnerable to Cross-Site Request Forgery since a capability check but no nonce check was added in 4.10.2.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-2301?

It affects 1 product.


Products: Vcita Contact Form Builder by Vcita.

## How do I fix CVE-2023-2301?

No fix has been published for CVE-2023-2301 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-2301 being exploited?

There is no known exploitation of CVE-2023-2301 in the wild and no public exploit code.

## Other vulnerabilities in eyale-vc Contact Form Builder by vcita

- [CVE-2023-2300](https://insights.sbomify.com/CVE-2023-2300/): Contact Form Builder by vcita <= 4.9.1 - Authenticated (Contributor+) Stored Cross-Site Scripting (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-2301 and fix it if it is affected.

What it is: CVE-2023-2301 is a medium-severity vulnerability in eyale-vc Contact Form Builder by vcita, published on 3 Jun 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-2301 in the wild and no public exploit code.

Affected product: eyale-vc Contact Form Builder by vcita. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-2301/ (Markdown: https://insights.sbomify.com/CVE-2023-2301/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-2301
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-2301
- OSV: https://osv.dev/vulnerability/CVE-2023-2301

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-2301/
Summaries are generated and may contain mistakes; the official description above is the record.
