# CVE-2023-2315: Path Traversal in OpenCart versions 4.0.0.0 to 4.0.2.2

> Authenticated users with log access can delete arbitrary files on the server via path traversal in OpenCart.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2023
- **Updated:** 24 Sep 2024
- **Also known as:** GHSA-v4j2-cwmm-xg89

## What is CVE-2023-2315?

CVE-2023-2315 is a high-severity path traversal vulnerability in Opencart, published on 26 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Path Traversal in OpenCart versions 4.0.0.0 to 4.0.2.2 allows an authenticated user with access/modify privilege on the Log component to empty out arbitrary files on the server

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-2315?

2 open source packages ship an affected version, including opencart/opencart. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opencart/opencart` | Packagist | From 4.0.0.0 | 4.0.2.3 |
| `opencart/opencart` | Packagist | From 4.0.0.0 | 4.0.2.3 |

Products: Opencart Opencart.

## How do I fix CVE-2023-2315?

Upgrade opencart/opencart to 4.0.2.3 or later.

## Is CVE-2023-2315 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2315 exists.

## Other vulnerabilities in Opencart

- [CVE-2023-40834](https://insights.sbomify.com/CVE-2023-40834/): Auth bypass in n/a (critical 9.8)
- [CVE-2014-3990](https://insights.sbomify.com/CVE-2014-3990/): Deserialization in n/a (critical 9.8)
- [CVE-2024-58341](https://insights.sbomify.com/CVE-2024-58341/): OpenCart Core 4.0.2.3 SQL Injection via search Parameter (high 8.8)
- [CVE-2023-47444](https://insights.sbomify.com/CVE-2023-47444/): Code injection in n/a (high 8.8)
- [CVE-2018-13067](https://insights.sbomify.com/CVE-2018-13067/): OpenCart Cross-Site Request Forgery (CSRF) (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-2315 and fix it if it is affected.

What it is: CVE-2023-2315 is a high-severity path traversal vulnerability in Opencart, published on 26 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2315 exists.

Affected packages and fixed versions:
- opencart/opencart (Packagist): affected from 4.0.0.0; fixed in 4.0.2.3
- opencart/opencart (Packagist): affected from 4.0.0.0; fixed in 4.0.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-2315/ (Markdown: https://insights.sbomify.com/CVE-2023-2315/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-2315
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-2315
- OSV: https://osv.dev/vulnerability/CVE-2023-2315

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-2315/
Summaries are generated and may contain mistakes; the official description above is the record.
