# CVE-2023-2361: Cross-site Scripting (XSS) - Stored in pimcore/pimcore

> Attackers can inject malicious scripts into Pimcore CMS, potentially executing code or hijacking user sessions.

- **Severity:** Medium 6.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Apr 2023
- **Updated:** 30 Jan 2025
- **Also known as:** GHSA-9xg6-75mh-7x3f

## What is CVE-2023-2361?

CVE-2023-2361 is a medium-severity cross-site scripting vulnerability in Pimcore Pimcore, published on 28 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Cross-site Scripting (XSS) - Stored in GitHub repository pimcore/pimcore prior to 10.5.21.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-2361?

2 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/pimcore` | Packagist | All versions | 10.5.21 |
| `pimcore/pimcore` | Packagist | All versions | 10.5.21 |

Products: Pimcore Pimcore.

## How do I fix CVE-2023-2361?

Upgrade pimcore/pimcore to 10.5.21 or later.

## Is CVE-2023-2361 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2361 exists.

## Other vulnerabilities in Pimcore Pimcore

- [CVE-2022-39365](https://insights.sbomify.com/CVE-2022-39365/): RCE vulnerability in Pimcore/Mail & Dynamic Text Layout (critical 9.8)
- [CVE-2019-18981](https://insights.sbomify.com/CVE-2019-18981/): Pimcore Access Control Issues (critical 9.8)
- [CVE-2019-18985](https://insights.sbomify.com/CVE-2019-18985/): Pimcore 2FA Vulnerable to Brute Forcing (critical 9.8)
- [CVE-2026-23492](https://insights.sbomify.com/CVE-2026-23492/): Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848 (high 8.8)
- [CVE-2023-47637](https://insights.sbomify.com/CVE-2023-47637/): SQL Injection in Admin Grid Filter API in Pimcore (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-2361 and fix it if it is affected.

What it is: CVE-2023-2361 is a medium-severity cross-site scripting vulnerability in Pimcore Pimcore, published on 28 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-2361 exists.

Affected packages and fixed versions:
- pimcore/pimcore (Packagist): affected all versions; fixed in 10.5.21
- pimcore/pimcore (Packagist): affected all versions; fixed in 10.5.21

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-2361/ (Markdown: https://insights.sbomify.com/CVE-2023-2361/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-2361
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-2361
- OSV: https://osv.dev/vulnerability/CVE-2023-2361

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-2361/
Summaries are generated and may contain mistakes; the official description above is the record.
