# CVE-2023-23610: glpi vulnerable to Unauthorized access to data export

> An authenticated user can export sensitive data from any GLPI item type, bypassing access controls to read unauthorized assets, tickets, and user information.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-6565-hm87-24hf, UBUNTU-CVE-2023-23610

## What is CVE-2023-23610?

CVE-2023-23610 is a medium-severity missing authorization vulnerability in Glpi-Project Glpi, published on 25 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GLPI is a Free Asset and IT Management Software package. Versions prior to 9.5.12 and 10.0.6 are vulnerable to Improper Privilege Management. Any user having access to the standard interface can export data of almost any GLPI item type, even those on which user is not allowed to access (including assets, tickets, users, ...). This issue is patched in 10.0.6.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2023-23610?

It affects 1 product.


Products: Glpi-Project Glpi.

## How do I fix CVE-2023-23610?

No fix has been published for CVE-2023-23610 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-23610 being exploited?

There is no known exploitation of CVE-2023-23610 in the wild and no public exploit code.

## Other vulnerabilities in Glpi-Project Glpi

- [CVE-2022-35914](https://insights.sbomify.com/CVE-2022-35914/): Teclib GLPI Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2023-42802](https://insights.sbomify.com/CVE-2023-42802/): GLPI vulnerable to unallowed PHP script execution (critical 10.0)
- [CVE-2023-28849](https://insights.sbomify.com/CVE-2023-28849/): GLPI vulnerable to SQL injection and Stored XSS via inventory agent request (critical 10.0)
- [CVE-2022-35947](https://insights.sbomify.com/CVE-2022-35947/): SQL injection in GLPI (critical 10.0)
- [CVE-2022-31056](https://insights.sbomify.com/CVE-2022-31056/): SQL injection with _actor parameter in GLPI (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-23610 and fix it if it is affected.

What it is: CVE-2023-23610 is a medium-severity missing authorization vulnerability in Glpi-Project Glpi, published on 25 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-23610 in the wild and no public exploit code.

Affected product: Glpi-Project Glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-23610/ (Markdown: https://insights.sbomify.com/CVE-2023-23610/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-23610
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-23610
- OSV: https://osv.dev/vulnerability/CVE-2023-23610

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-23610/
Summaries are generated and may contain mistakes; the official description above is the record.
