CVE-2023-23611 xblock-lti-consumer contain Missing Authorization in Grade Pass Back Implementation

Medium 5.4 Published Updated

A malicious LTI tool can modify grades for any LTI XBlock on the Open edX platform by guessing block locations, compromising grade integrity.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-23611?

CVE-2023-23611 is a medium-severity missing authorization vulnerability in openedx xblock-lti-consumer, published on 25 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

LTI Consumer XBlock implements the consumer side of the LTI specification enabling integration of third-party LTI provider tools. Versions 7.0.0 and above, prior to 7.2.2, are vulnerable to Missing Authorization. Any LTI tool that is integrated with on the Open edX platform can post a grade back for any LTI XBlock so long as it knows or can guess the block location for that XBlock. An LTI tool submits scores to the edX platform for line items. The code that uploads that score to the LMS grade tables determines which XBlock to upload the grades for by reading the resource_link_id field of the associated line item. The LTI tool may submit any value for the resource_link_id field, allowing a malicious LTI tool to submit scores for any LTI XBlock on the platform. The impact is a loss of integrity for LTI XBlock grades. This issue is patched in 7.2.2. No workarounds exist.

Weakness: CWE-862

Which versions are affected by CVE-2023-23611?

3 open source packages ship an affected version, including lti-consumer-xblock. It affects 1 product.

PackageAffectedFixed in
lti-consumer-xblock PyPIFrom 7.0.07.2.2
lti-consumer-xblock PyPIFrom 7.0.07.2.2
lti-consumer-xblock PyPIFrom 7.0.07.2.2

Products include Openedx Xblock-Lti-Consumer.

How do I fix CVE-2023-23611?

Upgrade lti-consumer-xblock to 7.2.2 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-23611 being exploited?

There is no known exploitation of CVE-2023-23611 in the wild and no public exploit code.

Sources

Also known as GHSA-7j9p-67mm-5g87, PYSEC-2023-21.

Is CVE-2023-23611 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free