# CVE-2023-23611: xblock-lti-consumer contain Missing Authorization in Grade Pass Back Implementation

> A malicious LTI tool can modify grades for any LTI XBlock on the Open edX platform by guessing block locations, compromising grade integrity.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-7j9p-67mm-5g87, PYSEC-2023-21

## What is CVE-2023-23611?

CVE-2023-23611 is a medium-severity missing authorization vulnerability in openedx xblock-lti-consumer, published on 25 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LTI Consumer XBlock implements the consumer side of the LTI specification enabling integration of third-party LTI provider tools. Versions 7.0.0 and above, prior to 7.2.2, are vulnerable to Missing Authorization.  Any LTI tool that is integrated with on the Open edX platform can post a grade back for any LTI XBlock so long as it knows or can guess the block location for that XBlock. An LTI tool submits scores to the edX platform for line items. The code that uploads that score to the LMS grade tables determines which XBlock to upload the grades for by reading the resource_link_id field of the associated line item. The LTI tool may submit any value for the resource_link_id field, allowing a malicious LTI tool to submit scores for any LTI XBlock on the platform. The impact is a loss of integrity for LTI XBlock grades. This issue is patched in 7.2.2. No workarounds exist.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-23611?

3 open source packages ship an affected version, including lti-consumer-xblock. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lti-consumer-xblock` | PyPI | From 7.0.0 | 7.2.2 |
| `lti-consumer-xblock` | PyPI | From 7.0.0 | 7.2.2 |
| `lti-consumer-xblock` | PyPI | From 7.0.0 | 7.2.2 |

Products: Openedx Xblock-Lti-Consumer.

## How do I fix CVE-2023-23611?

Upgrade lti-consumer-xblock to 7.2.2 or later.

## Is CVE-2023-23611 being exploited?

There is no known exploitation of CVE-2023-23611 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-23611 and fix it if it is affected.

What it is: CVE-2023-23611 is a medium-severity missing authorization vulnerability in openedx xblock-lti-consumer, published on 25 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-23611 in the wild and no public exploit code.

Affected packages and fixed versions:
- lti-consumer-xblock (PyPI): affected from 7.0.0; fixed in 7.2.2
- lti-consumer-xblock (PyPI): affected from 7.0.0; fixed in 7.2.2
- lti-consumer-xblock (PyPI): affected from 7.0.0; fixed in 7.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-23611/ (Markdown: https://insights.sbomify.com/CVE-2023-23611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-23611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-23611
- OSV: https://osv.dev/vulnerability/CVE-2023-23611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-23611/
Summaries are generated and may contain mistakes; the official description above is the record.
