CVE-2023-23614 Improper session handling of "Remember me for 7 days" functionality

High 8.8 Published Updated

Attackers can bypass authentication or reuse expired cookies by exploiting improper session handling that exposes the admin password hash.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-23614?

CVE-2023-23614 is a high-severity authentication bypass vulnerability in pi-hole AdminLTE, published on 26 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Pi-hole®'s Web interface (based off of AdminLTE) provides a central location to manage your Pi-hole. Versions 4.0 and above, prior to 5.18.3 are vulnerable to Insufficient Session Expiration. Improper use of admin WEBPASSWORD hash as "Remember me for 7 days" cookie value makes it possible for an attacker to "pass the hash" to login or reuse a theoretically expired "remember me" cookie. It also exposes the hash over the network and stores it unnecessarily in the browser. The cookie itself is set to expire after 7 days but its value will remain valid as long as the admin password doesn't change. If a cookie is leaked or compromised it could be used forever as long as the admin password is not changed. An attacker that obtained the password hash via an other attack vector (for example a path traversal vulnerability) could use it to login as the admin by setting the hash as the cookie value without the need to crack it to obtain the admin password (pass the hash). The hash is exposed over the network and in the browser where the cookie is transmitted and stored. This issue is patched in version 5.18.3.

Weakness: CWE-836, CWE-613

Which versions are affected by CVE-2023-23614?

It affects 1 product.

Products include Pi-Hole Web Interface.

How do I fix CVE-2023-23614?

No fix has been published for CVE-2023-23614 yet. Limit exposure of the affected software until one is available.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2023-23614 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-23614 exists.

Sources

Also known as GHSA-33w4-xf7m-f82m.

Is CVE-2023-23614 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free