# CVE-2023-23614: Improper session handling of "Remember me for 7 days" functionality

> Attackers can bypass authentication or reuse expired cookies by exploiting improper session handling that exposes the admin password hash.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-33w4-xf7m-f82m

## What is CVE-2023-23614?

CVE-2023-23614 is a high-severity authentication bypass vulnerability in pi-hole AdminLTE, published on 26 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Pi-hole®'s Web interface (based off of AdminLTE) provides a central location to manage your Pi-hole. Versions 4.0 and above, prior to 5.18.3 are vulnerable to Insufficient Session Expiration. Improper use of admin WEBPASSWORD hash as "Remember me for 7 days" cookie value makes it possible for an attacker to "pass the hash" to login or reuse a theoretically expired "remember me" cookie. It also exposes the hash over the network and stores it unnecessarily in the browser. The cookie itself is set to expire after 7 days but its value will remain valid as long as the admin password doesn't change. If a cookie is leaked or compromised it could be used forever as long as the admin password is not changed. An attacker that obtained the password hash via an other attack vector (for example a path traversal vulnerability) could use it to login as the admin by setting the hash as the cookie value without the need to crack it to obtain the admin password (pass the hash). The hash is exposed over the network and in the browser where the cookie is transmitted and stored. This issue is patched in version 5.18.3.

Weakness: CWE-836 (Use of Password Hash Instead of Password for Authentication), CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2023-23614?

It affects 1 product.


Products: Pi-Hole Web Interface.

## How do I fix CVE-2023-23614?

No fix has been published for CVE-2023-23614 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-23614 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-23614 exists.

## Other vulnerabilities in pi-hole AdminLTE

- [CVE-2026-33765](https://insights.sbomify.com/CVE-2026-33765/): Pi-hole Web Interface has a Command Injection Vulnerability (high 8.9)
- [CVE-2025-59151](https://insights.sbomify.com/CVE-2025-59151/): Pi-hole Admin Interface vulnerable to HTTP response header injection via CRLF injection (high 8.2)
- [CVE-2021-3706](https://insights.sbomify.com/CVE-2021-3706/): Sensitive Cookie Without 'HttpOnly' Flag in pi-hole/adminlte (high 7.4)
- [CVE-2021-41175](https://insights.sbomify.com/CVE-2021-41175/): Stored XSS in Client Groups Management (Authenticated) (high 7.3)
- [CVE-2021-3811](https://insights.sbomify.com/CVE-2021-3811/): Cross-site Scripting (XSS) - Reflected in pi-hole/adminlte (medium 6.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-23614 and fix it if it is affected.

What it is: CVE-2023-23614 is a high-severity authentication bypass vulnerability in pi-hole AdminLTE, published on 26 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-23614 exists.

Affected product: pi-hole AdminLTE. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-23614/ (Markdown: https://insights.sbomify.com/CVE-2023-23614/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-23614
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-23614
- OSV: https://osv.dev/vulnerability/CVE-2023-23614

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-23614/
Summaries are generated and may contain mistakes; the official description above is the record.
