CVE-2023-23617 OpenMage LTS has DoS vulnerability in MaliciousCode filter

Medium 4.9 Published Updated

An attacker can cause a denial of service via an infinite loop in the malicious code filter of the OpenMage e-commerce platform.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-23617?

CVE-2023-23617 is a medium-severity denial of service vulnerability in OpenMage magento-lts, published on 27 Jan 2023. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

OpenMage LTS is an e-commerce platform. Versions prior to 19.4.22 and 20.0.19 contain an infinite loop in malicious code filter in certain conditions. Versions 19.4.22 and 20.0.19 have a fix for this issue. There are no known workarounds.

Weakness: CWE-835

Which versions are affected by CVE-2023-23617?

4 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.

PackageAffectedFixed in
openmage/magento-lts PackagistAll versions19.4.22
openmage/magento-lts PackagistAll versions19.4.22
openmage/magento-lts PackagistFrom 20.0.020.0.19
openmage/magento-lts PackagistFrom 20.0.020.0.19

Products include Openmage Magento.

How do I fix CVE-2023-23617?

Upgrade openmage/magento-lts to a fixed version for your release line: 19.4.22 or 20.0.19.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-23617 being exploited?

There is no known exploitation of CVE-2023-23617 in the wild and no public exploit code.

Sources

Also known as GHSA-3p73-mm7v-4f6m.

Is CVE-2023-23617 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free