{"answers":{"affected":"4 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-23617 in the wild and no public exploit code.","fix":"Upgrade openmage/magento-lts to a fixed version for your release line: 19.4.22 or 20.0.19.","what":"CVE-2023-23617 is a medium-severity denial of service vulnerability in OpenMage magento-lts, published on 27 Jan 2023. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-23617 and fix it if it is affected.\n\nWhat it is: CVE-2023-23617 is a medium-severity denial of service vulnerability in OpenMage magento-lts, published on 27 Jan 2023. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-23617 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openmage/magento-lts (Packagist): affected all versions; fixed in 19.4.22\n- openmage/magento-lts (Packagist): affected all versions; fixed in 19.4.22\n- openmage/magento-lts (Packagist): affected from 20.0.0; fixed in 20.0.19\n- openmage/magento-lts (Packagist): affected from 20.0.0; fixed in 20.0.19\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-23617/ (Markdown: https://insights.sbomify.com/CVE-2023-23617/index.md)","id":"CVE-2023-23617","markdown":"https://insights.sbomify.com/CVE-2023-23617/index.md","name":"CVE-2023-23617","record":{"aliases":["GHSA-3p73-mm7v-4f6m"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenMage e-commerce platform","requires_auth":"high_privilege","summary":"An attacker can cause a denial of service via an infinite loop in the malicious code filter of the OpenMage e-commerce platform.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"magento","vendor":"openmage"}],"cvss":{"score":4.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"}],"description":"OpenMage LTS is an e-commerce platform. Versions prior to 19.4.22 and 20.0.19 contain an infinite loop in malicious code filter in certain conditions. Versions 19.4.22 and 20.0.19 have a fix for this issue. There are no known workarounds.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenMage LTS has DoS vulnerability in MaliciousCode filter","id":"CVE-2023-23617","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":4,"n_references":4,"next":{"headline":"gitk can inadvertently call executables in the worktree","id":"CVE-2023-23618"},"packages":[{"ecosystem":"Packagist","fixed":["19.4.22"],"introduced":["0"],"last_affected":[],"package":"openmage/magento-lts","purl":null,"source":"GHSA-3p73-mm7v-4f6m"},{"ecosystem":"Packagist","fixed":["19.4.22"],"introduced":["0"],"last_affected":[],"package":"openmage/magento-lts","purl":"pkg:composer/openmage/magento-lts","source":"GHSA-3p73-mm7v-4f6m"},{"ecosystem":"Packagist","fixed":["20.0.19"],"introduced":["20.0.0"],"last_affected":[],"package":"openmage/magento-lts","purl":null,"source":"GHSA-3p73-mm7v-4f6m"},{"ecosystem":"Packagist","fixed":["20.0.19"],"introduced":["20.0.0"],"last_affected":[],"package":"openmage/magento-lts","purl":"pkg:composer/openmage/magento-lts","source":"GHSA-3p73-mm7v-4f6m"}],"prev":{"headline":"Discourse membership requests lack character limit","id":"CVE-2023-23616"},"products":["magento-lts"],"published":"2023-01-27","related":[{"cvss_score":9.8,"headline":"Fixes a bug in Zend Framework's Stream HTTP Wrapper","id":"CVE-2021-21426","kev_date_added":null,"published":"2021-04-21"},{"cvss_score":9.1,"headline":"Backport for CVE-2021-21024 Blind SQLi from Magento 2","id":"CVE-2021-21427","kev_date_added":null,"published":"2021-04-21"},{"cvss_score":8.8,"headline":"OpenMage LTS authenticated remote code execution through layout update","id":"CVE-2021-41144","kev_date_added":null,"published":"2023-01-27"},{"cvss_score":8.7,"headline":"OpenMage LTS has Customer File Upload Extension Blocklist Bypass that Leads to Remote Code Execution","id":"CVE-2026-40488","kev_date_added":null,"published":"2026-04-20"},{"cvss_score":8.1,"headline":"OpenMage LTS's Phar Deserialization leads to Remote Code Execution","id":"CVE-2026-25524","kev_date_added":null,"published":"2026-04-20"},{"cvss_score":8,"headline":"RCE in Magento","id":"CVE-2020-15244","kev_date_added":null,"published":"2020-10-21"},{"cvss_score":7.5,"headline":"Magento LTS's guest order \"protect code\" can be brute-forced too easily","id":"CVE-2023-41879","kev_date_added":null,"published":"2023-09-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["OpenMage"]},"summary":"An attacker can cause a denial of service via an infinite loop in the malicious code filter of the OpenMage e-commerce platform.","url":"https://insights.sbomify.com/CVE-2023-23617/"}