CVE-2023-23621 Discourse vulnerable to ReDoS in user agent parsing

High 8.6 Published Updated

A malicious user can cause a regular expression denial of service in Discourse by sending a carefully crafted user agent string.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-23621?

CVE-2023-23621 is a high-severity denial of service vulnerability in Discourse Discourse, published on 27 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Discourse is an open-source discussion platform. Prior to version 3.0.1 on the `stable` branch and version 3.1.0.beta2 on the `beta` and `tests-passed` branches, a malicious user can cause a regular expression denial of service using a carefully crafted user agent. This issue is patched in version 3.0.1 on the `stable` branch and version 3.1.0.beta2 on the `beta` and `tests-passed` branches. There are no known workarounds.

Weakness: CWE-1333

Which versions are affected by CVE-2023-23621?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.0.1

Products include Discourse Discourse.

How do I fix CVE-2023-23621?

Upgrade discourse to 3.0.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-23621 being exploited?

There is no known exploitation of CVE-2023-23621 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2023-23621, GHSA-mrfp-54hf-jrcv.

Is CVE-2023-23621 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free