# CVE-2023-23623: Content-Secrity-Policy disabling eval not applied consistently in renderers with sandbox disabled in Electron

> Electron fails to enforce Content-Security-Policy restrictions on eval in unsandboxed renderers, allowing attackers to execute arbitrary code if sandboxing is disabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Sep 2023
- **Updated:** 26 Sep 2024
- **Also known as:** GHSA-gxh7-wv9q-fwfr

## What is CVE-2023-23623?

CVE-2023-23623 is a high-severity vulnerability in Electronjs Electron, published on 6 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS. A Content-Security-Policy that disables eval, specifically setting a `script-src` directive and _not_ providing `unsafe-eval` in that directive, is not respected in renderers that have sandbox disabled.  i.e. `sandbox: false` in the `webPreferences` object. This allows usage of methods like `eval()` and `new Function` unexpectedly which can result in an expanded attack surface. This issue only ever affected the 22 and 23 major versions of Electron and has been fixed in the latest versions of those release lines. Specifically, these versions contain the fixes: 22.0.1 and 23.0.0-alpha.2 We recommend all apps upgrade to the latest stable version of Electron. If upgrading isn't possible, this issue can be addressed without upgrading by enabling `sandbox: true` on all renderers.

Weakness: CWE-670 (Always-Incorrect Control Flow Implementation)

## Which versions are affected by CVE-2023-23623?

4 open source packages ship an affected version, including electron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | From 22.0.0-beta.1 | 22.0.1 |
| `electron` | npm | From 22.0.0-beta.1 | 22.0.1 |
| `electron` | npm | From 23.0.0-alpha.1 | 23.0.0-alpha.2 |
| `electron` | npm | From 23.0.0-alpha.1 | 23.0.0-alpha.2 |

Products: Electronjs Electron.

## How do I fix CVE-2023-23623?

Upgrade electron to a fixed version for your release line: 22.0.1 or 23.0.0-alpha.2.

## Is CVE-2023-23623 being exploited?

There is no known exploitation of CVE-2023-23623 in the wild and no public exploit code.

## Other vulnerabilities in Electronjs Electron

- [CVE-2017-16151](https://insights.sbomify.com/CVE-2017-16151/): Chromium Remote Code Execution in electron (critical 9.8)
- [CVE-2018-1000118](https://insights.sbomify.com/CVE-2018-1000118/): Electron protocol handler browser vulnerable to Command Injection (high 8.8)
- [CVE-2026-34780](https://insights.sbomify.com/CVE-2026-34780/): Electron: Context Isolation bypass via contextBridge VideoFrame transfer (high 8.4)
- [CVE-2026-102676](https://insights.sbomify.com/CVE-2026-102676/): Electron: <webview> can enable Node.js integration in Web Workers despite embedder restrictions (high 8.3)
- [CVE-2026-102673](https://insights.sbomify.com/CVE-2026-102673/): Electron drops inherited HTML sandbox restrictions for popups opened through OpenURLFromTab (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-23623 and fix it if it is affected.

What it is: CVE-2023-23623 is a high-severity vulnerability in Electronjs Electron, published on 6 Sep 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-23623 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected from 22.0.0-beta.1; fixed in 22.0.1
- electron (npm): affected from 22.0.0-beta.1; fixed in 22.0.1
- electron (npm): affected from 23.0.0-alpha.1; fixed in 23.0.0-alpha.2
- electron (npm): affected from 23.0.0-alpha.1; fixed in 23.0.0-alpha.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-23623/ (Markdown: https://insights.sbomify.com/CVE-2023-23623/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-23623
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-23623
- OSV: https://osv.dev/vulnerability/CVE-2023-23623

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-23623/
Summaries are generated and may contain mistakes; the official description above is the record.
