# CVE-2023-23625: Denial of service in HAMT Decoding in go-unixfs

> Attackers can cause denial of service via panics and memory leaks by providing malformed HAMT directory data to the go-unixfs library.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-q264-w97q-q778, GO-2023-1557

## What is CVE-2023-23625?

CVE-2023-23625 is a medium-severity denial of service vulnerability in ipfs go-unixfs, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

go-unixfs is an implementation of a unix-like filesystem on top of an ipld merkledag. Trying to read malformed HAMT sharded directories can cause panics and virtual memory leaks. If you are reading untrusted user input, an attacker can then trigger a panic. This is caused by bogus `fanout` parameter in the HAMT directory nodes. Users are advised to upgrade to version 0.4.3 to resolve this issue. Users unable to upgrade should not feed untrusted user data to the decoding functions.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-23625?

3 open source packages ship an affected version, including github.com/ipfs/go-unixfs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ipfs/go-unixfs` | Go | All versions | 0.4.3 |
| `github.com/ipfs/go-unixfs` | Go | All versions | 0.4.3 |
| `github.com/ipfs/go-unixfs` | Go | All versions | 0.4.3 |

Products: Protocol Go-Unixfs.

## How do I fix CVE-2023-23625?

Upgrade github.com/ipfs/go-unixfs to 0.4.3 or later.

## Is CVE-2023-23625 being exploited?

There is no known exploitation of CVE-2023-23625 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-23625 and fix it if it is affected.

What it is: CVE-2023-23625 is a medium-severity denial of service vulnerability in ipfs go-unixfs, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-23625 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ipfs/go-unixfs (Go): affected all versions; fixed in 0.4.3
- github.com/ipfs/go-unixfs (Go): affected all versions; fixed in 0.4.3
- github.com/ipfs/go-unixfs (Go): affected all versions; fixed in 0.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-23625/ (Markdown: https://insights.sbomify.com/CVE-2023-23625/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-23625
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-23625
- OSV: https://osv.dev/vulnerability/CVE-2023-23625

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-23625/
Summaries are generated and may contain mistakes; the official description above is the record.
