{"answers":{"affected":"2 open source packages ship an affected version, including sanitize. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-23627 in the wild and no public exploit code.","fix":"Upgrade sanitize to 6.0.1 or later.","what":"CVE-2023-23627 is a medium-severity cross-site scripting vulnerability in rgrove sanitize, published on 27 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-23627 and fix it if it is affected.\n\nWhat it is: CVE-2023-23627 is a medium-severity cross-site scripting vulnerability in rgrove sanitize, published on 27 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-23627 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sanitize (RubyGems): affected from 5.0.0; fixed in 6.0.1\n- sanitize (RubyGems): affected from 5.0.0; fixed in 6.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-23627/ (Markdown: https://insights.sbomify.com/CVE-2023-23627/index.md)","id":"CVE-2023-23627","markdown":"https://insights.sbomify.com/CVE-2023-23627/index.md","name":"CVE-2023-23627","record":{"aliases":["DEBIAN-CVE-2023-23627","GHSA-fw3g-2h3j-qmm7","UBUNTU-CVE-2023-23627"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Ruby HTML sanitizer","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in browsers if the Sanitize library is configured with a custom allowlist permitting noscript elements.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sanitize","vendor":"sanitize_project"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Sanitize is an allowlist-based HTML and CSS sanitizer. Versions 5.0.0 and later, prior to 6.0.1, are vulnerable to Cross-site Scripting. When Sanitize is configured with a custom allowlist that allows `noscript` elements, attackers are able to include arbitrary HTML, resulting in XSS (cross-site scripting) or other undesired behavior when that HTML is rendered in a browser. The default configurations do not allow `noscript` elements and are not vulnerable. This issue only affects users who are using a custom config that adds `noscript` to the element allowlist. This issue has been patched in version 6.0.1. Users who are unable to upgrade can prevent this issue by using one of Sanitize's default configs or by ensuring that their custom config does not include `noscript` in the element allowlist.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sanitize vulnerable to Cross-site Scripting via Improper neutralization of `noscript` element","id":"CVE-2023-23627","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Metabase subject to Exposure of Sensitive Information to an Unauthorized Actor","id":"CVE-2023-23628"},"packages":[{"ecosystem":"RubyGems","fixed":["6.0.1"],"introduced":["5.0.0"],"last_affected":[],"package":"sanitize","purl":null,"source":"GHSA-fw3g-2h3j-qmm7"},{"ecosystem":"RubyGems","fixed":["6.0.1"],"introduced":["5.0.0"],"last_affected":[],"package":"sanitize","purl":"pkg:gem/sanitize","source":"GHSA-fw3g-2h3j-qmm7"}],"prev":{"headline":"Denial of service when feeding malformed size arguments in go-bitfield","id":"CVE-2023-23626"},"products":["sanitize"],"published":"2023-01-27","related":[{"cvss_score":7.5,"headline":"Sanitize vulnerable to Improper Input Validation and Cross-site Scripting","id":"CVE-2018-3740","kev_date_added":null,"published":"2018-03-30"},{"cvss_score":7.3,"headline":"Cross-site Scripting in Sanitize","id":"CVE-2020-4054","kev_date_added":null,"published":"2020-06-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["rgrove"]},"summary":"Attackers can execute arbitrary scripts in browsers if the Sanitize library is configured with a custom allowlist permitting noscript elements.","url":"https://insights.sbomify.com/CVE-2023-23627/"}