# CVE-2023-23627: Sanitize vulnerable to Cross-site Scripting via Improper neutralization of `noscript` element

> Attackers can execute arbitrary scripts in browsers if the Sanitize library is configured with a custom allowlist permitting noscript elements.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jan 2023
- **Updated:** 10 Mar 2025
- **Also known as:** DEBIAN-CVE-2023-23627, GHSA-fw3g-2h3j-qmm7, UBUNTU-CVE-2023-23627

## What is CVE-2023-23627?

CVE-2023-23627 is a medium-severity cross-site scripting vulnerability in rgrove sanitize, published on 27 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Sanitize is an allowlist-based HTML and CSS sanitizer. Versions 5.0.0 and later, prior to 6.0.1, are vulnerable to Cross-site Scripting. When Sanitize is configured with a custom allowlist that allows `noscript` elements, attackers are able to include arbitrary HTML, resulting in XSS (cross-site scripting) or other undesired behavior when that HTML is rendered in a browser. The default configurations do not allow `noscript` elements and are not vulnerable. This issue only affects users who are using a custom config that adds `noscript` to the element allowlist. This issue has been patched in version 6.0.1. Users who are unable to upgrade can prevent this issue by using one of Sanitize's default configs or by ensuring that their custom config does not include `noscript` in the element allowlist.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-23627?

2 open source packages ship an affected version, including sanitize. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sanitize` | RubyGems | From 5.0.0 | 6.0.1 |
| `sanitize` | RubyGems | From 5.0.0 | 6.0.1 |

Products: Sanitize Project Sanitize.

## How do I fix CVE-2023-23627?

Upgrade sanitize to 6.0.1 or later.

## Is CVE-2023-23627 being exploited?

There is no known exploitation of CVE-2023-23627 in the wild and no public exploit code.

## Other vulnerabilities in rgrove sanitize

- [CVE-2018-3740](https://insights.sbomify.com/CVE-2018-3740/): Sanitize vulnerable to Improper Input Validation and Cross-site Scripting (high 7.5)
- [CVE-2020-4054](https://insights.sbomify.com/CVE-2020-4054/): Cross-site Scripting in Sanitize (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-23627 and fix it if it is affected.

What it is: CVE-2023-23627 is a medium-severity cross-site scripting vulnerability in rgrove sanitize, published on 27 Jan 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-23627 in the wild and no public exploit code.

Affected packages and fixed versions:
- sanitize (RubyGems): affected from 5.0.0; fixed in 6.0.1
- sanitize (RubyGems): affected from 5.0.0; fixed in 6.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-23627/ (Markdown: https://insights.sbomify.com/CVE-2023-23627/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-23627
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-23627
- OSV: https://osv.dev/vulnerability/CVE-2023-23627

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-23627/
Summaries are generated and may contain mistakes; the official description above is the record.
