{"answers":{"affected":"2 open source packages ship an affected version, including eta. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-23630 in the wild and no public exploit code.","fix":"Upgrade eta to 2.0.0 or later.","what":"CVE-2023-23630 is a high-severity cross-site scripting vulnerability in eta-dev eta, published on 1 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-23630 and fix it if it is affected.\n\nWhat it is: CVE-2023-23630 is a high-severity cross-site scripting vulnerability in eta-dev eta, published on 1 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-23630 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- eta (npm): affected all versions; fixed in 2.0.0\n- eta (npm): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-23630/ (Markdown: https://insights.sbomify.com/CVE-2023-23630/index.md)","id":"CVE-2023-23630","markdown":"https://insights.sbomify.com/CVE-2023-23630/index.md","name":"CVE-2023-23630","record":{"aliases":["GHSA-xrh7-m5pp-39r6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript templating library","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in user browsers via XSS in the Eta templating engine's Express API integration.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"eta","vendor":"eta.js"}],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Eta is an embedded JS templating engine that works inside Node, Deno, and the browser. XSS attack - anyone using the Express API is impacted. The problem has been resolved. Users should upgrade to version 2.0.0. As a workaround, don't pass user supplied things directly to `res.render`.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site (XSS) vulnerability with Express API in Eta","id":"CVE-2023-23630","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"HAMT Decoding Panics in github.com/ipfs/go-unixfsnode","id":"CVE-2023-23631"},"packages":[{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"eta","purl":null,"source":"GHSA-xrh7-m5pp-39r6"},{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"eta","purl":"pkg:npm/eta","source":"GHSA-xrh7-m5pp-39r6"}],"prev":{"headline":"Metabase subject to Improper Privilege Management","id":"CVE-2023-23629"},"products":["eta"],"published":"2023-02-01","related":[{"cvss_score":8.1,"headline":"Eta vulnerable to Code Injection via templates rendered with user-defined data","id":"CVE-2022-25967","kev_date_added":null,"published":"2023-01-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["eta-dev"]},"summary":"Attackers can execute arbitrary scripts in user browsers via XSS in the Eta templating engine's Express API integration.","url":"https://insights.sbomify.com/CVE-2023-23630/"}