# CVE-2023-23630: Cross-site (XSS) vulnerability with Express API in Eta

> Attackers can execute arbitrary scripts in user browsers via XSS in the Eta templating engine's Express API integration.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Feb 2023
- **Updated:** 10 Mar 2025
- **Also known as:** GHSA-xrh7-m5pp-39r6

## What is CVE-2023-23630?

CVE-2023-23630 is a high-severity cross-site scripting vulnerability in eta-dev eta, published on 1 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Eta is an embedded JS templating engine that works inside Node, Deno, and the browser. XSS attack - anyone using the Express API is impacted. The problem has been resolved. Users should upgrade to version 2.0.0. As a workaround, don't pass user supplied things directly to `res.render`.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-23630?

2 open source packages ship an affected version, including eta. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `eta` | npm | All versions | 2.0.0 |
| `eta` | npm | All versions | 2.0.0 |

Products: Eta.js Eta.

## How do I fix CVE-2023-23630?

Upgrade eta to 2.0.0 or later.

## Is CVE-2023-23630 being exploited?

There is no known exploitation of CVE-2023-23630 in the wild and no public exploit code.

## Other vulnerabilities in eta-dev eta

- [CVE-2022-25967](https://insights.sbomify.com/CVE-2022-25967/): Eta vulnerable to Code Injection via templates rendered with user-defined data (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-23630 and fix it if it is affected.

What it is: CVE-2023-23630 is a high-severity cross-site scripting vulnerability in eta-dev eta, published on 1 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-23630 in the wild and no public exploit code.

Affected packages and fixed versions:
- eta (npm): affected all versions; fixed in 2.0.0
- eta (npm): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-23630/ (Markdown: https://insights.sbomify.com/CVE-2023-23630/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-23630
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-23630
- OSV: https://osv.dev/vulnerability/CVE-2023-23630

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-23630/
Summaries are generated and may contain mistakes; the official description above is the record.
