{"answers":{"affected":"3 open source packages ship an affected version, including github.com/ipfs/go-unixfsnode. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-23631 in the wild and no public exploit code.","fix":"Upgrade github.com/ipfs/go-unixfsnode to 1.5.2 or later.","what":"CVE-2023-23631 is a medium-severity denial of service vulnerability in ipfs go-unixfsnode, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-23631 and fix it if it is affected.\n\nWhat it is: CVE-2023-23631 is a medium-severity denial of service vulnerability in ipfs go-unixfsnode, published on 9 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-23631 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/ipfs/go-unixfsnode (Go): affected all versions; fixed in 1.5.2\n- github.com/ipfs/go-unixfsnode (Go): affected all versions; fixed in 1.5.2\n- github.com/ipfs/go-unixfsnode (Go): affected all versions; fixed in 1.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-23631/ (Markdown: https://insights.sbomify.com/CVE-2023-23631/index.md)","id":"CVE-2023-23631","markdown":"https://insights.sbomify.com/CVE-2023-23631/index.md","name":"CVE-2023-23631","record":{"aliases":["GHSA-4gj3-6r43-3wfc","GO-2023-1559"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Go IPFS library","requires_auth":"none","summary":"Attackers can cause application crashes and memory leaks by providing malformed HAMT directory data to the go-unixfsnode library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"go-unixfsnode","vendor":"protocol"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"github.com/ipfs/go-unixfsnode is an ADL IPLD prime node that wraps go-codec-dagpb's implementation of protobuf to enable pathing. In versions priot to 1.5.2 trying to read malformed HAMT sharded directories can cause panics and virtual memory leaks.\nIf you are reading untrusted user input, an attacker can then trigger a panic. This is caused by bogus fanout parameter in the HAMT directory nodes. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"HAMT Decoding Panics in github.com/ipfs/go-unixfsnode","id":"CVE-2023-23631","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":3,"n_references":4,"next":{"headline":"Auth bypass in n/a","id":"CVE-2023-23632"},"packages":[{"ecosystem":"Go","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"github.com/ipfs/go-unixfsnode","purl":null,"source":"GHSA-4gj3-6r43-3wfc"},{"ecosystem":"Go","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"github.com/ipfs/go-unixfsnode","purl":"pkg:golang/github.com/ipfs/go-unixfsnode","source":"GHSA-4gj3-6r43-3wfc"},{"ecosystem":"Go","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"github.com/ipfs/go-unixfsnode","purl":"pkg:golang/github.com/ipfs/go-unixfsnode","source":"GO-2023-1559"}],"prev":{"headline":"Cross-site (XSS) vulnerability with Express API in Eta","id":"CVE-2023-23630"},"products":["go-unixfsnode"],"published":"2023-02-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-10","vendors":["ipfs"]},"summary":"Attackers can cause application crashes and memory leaks by providing malformed HAMT directory data to the go-unixfsnode library.","url":"https://insights.sbomify.com/CVE-2023-23631/"}