# CVE-2023-23638: Apache Dubbo Deserialization Vulnerability Gadgets Bypass

> Attackers can execute arbitrary code via malicious deserialization in Apache Dubbo generic invoke, requiring an upgrade to secure versions.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Mar 2023
- **Updated:** 23 Oct 2024
- **Also known as:** GHSA-933g-v89r-x8pf

## What is CVE-2023-23638?

CVE-2023-23638 is a medium-severity unsafe deserialization vulnerability in Apache Dubbo, published on 8 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A deserialization vulnerability existed when dubbo generic invoke, which could lead to malicious code execution. 

This issue affects Apache Dubbo 2.7.x version 2.7.21 and prior versions; Apache Dubbo 3.0.x version 3.0.13 and prior versions; Apache Dubbo 3.1.x version 3.1.5 and prior versions.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-23638?

6 open source packages ship an affected version, including org.apache.dubbo:dubbo. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.dubbo:dubbo` | Maven | All versions | 2.7.22 |
| `org.apache.dubbo:dubbo` | Maven | All versions | 2.7.22 |
| `org.apache.dubbo:dubbo` | Maven | From 3.0.0 | 3.0.13 |
| `org.apache.dubbo:dubbo` | Maven | From 3.0.0 | 3.0.13 |
| `org.apache.dubbo:dubbo` | Maven | From 3.1.0 | 3.1.5 |
| `org.apache.dubbo:dubbo` | Maven | From 3.1.0 | 3.1.5 |

Products: Apache Dubbo.

## How do I fix CVE-2023-23638?

Upgrade org.apache.dubbo:dubbo to a fixed version for your release line: 2.7.22, 3.0.13 or 3.1.5.

## Is CVE-2023-23638 being exploited?

There is no known exploitation of CVE-2023-23638 in the wild and no public exploit code.

Public exploit code:

- Apache Dubbo (CVE-2023-23638)漏洞利用的工程化实践 (github_poc): https://github.com/YYHYlh/Apache-Dubbo-CVE-2023-23638-exp
- PoC of Apache Dubbo CVE-2023-23638 (github_poc): https://github.com/X1r0z/dubbo-rce
- https://github.com/cuijiung/dubbo-CVE-2023-23638 (github_poc): https://github.com/cuijiung/dubbo-CVE-2023-23638
- https://github.com/P4x1s/CVE-2023-23638-Tools (github_poc): https://github.com/P4x1s/CVE-2023-23638-Tools

## Other vulnerabilities in Apache Dubbo

- [CVE-2023-29234](https://insights.sbomify.com/CVE-2023-29234/): Bypass serialize checks in Apache Dubbo (critical 9.8)
- [CVE-2023-46279](https://insights.sbomify.com/CVE-2023-46279/): Apache Dubbo: Bypass deny serialize list check in Apache Dubbo (critical 9.8)
- [CVE-2021-32824](https://insights.sbomify.com/CVE-2021-32824/): Regular expression Denial of Service in MooTools (critical 9.8)
- [CVE-2022-39198](https://insights.sbomify.com/CVE-2022-39198/): Apache Dubbo Hession Deserialization Vulnerability Gadgets Bypass (critical 9.8)
- [CVE-2021-43297](https://insights.sbomify.com/CVE-2021-43297/): Dubbo Hessian cause RCE when parse error (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-23638 and fix it if it is affected.

What it is: CVE-2023-23638 is a medium-severity unsafe deserialization vulnerability in Apache Dubbo, published on 8 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-23638 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.dubbo:dubbo (Maven): affected all versions; fixed in 2.7.22
- org.apache.dubbo:dubbo (Maven): affected all versions; fixed in 2.7.22
- org.apache.dubbo:dubbo (Maven): affected from 3.0.0; fixed in 3.0.13
- org.apache.dubbo:dubbo (Maven): affected from 3.0.0; fixed in 3.0.13
- org.apache.dubbo:dubbo (Maven): affected from 3.1.0; fixed in 3.1.5
- org.apache.dubbo:dubbo (Maven): affected from 3.1.0; fixed in 3.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-23638/ (Markdown: https://insights.sbomify.com/CVE-2023-23638/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-23638
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-23638
- OSV: https://osv.dev/vulnerability/CVE-2023-23638

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-23638/
Summaries are generated and may contain mistakes; the official description above is the record.
