CVE-2023-23684 WordPress WPGraphQL Plugin <= 1.14.5 is vulnerable to Server Side Request Forgery (SSRF)

Medium 4.4 Published Updated

An attacker can exploit a Server-Side Request Forgery vulnerability in the WPGraphQL WordPress plugin to access internal resources or bypass security controls.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-23684?

CVE-2023-23684 is a medium-severity server-side request forgery vulnerability in WPGraphQL, published on 13 Nov 2023. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Server-Side Request Forgery (SSRF) vulnerability in WPGraphQL.This issue affects WPGraphQL: from n/a through 1.14.5.

Weakness: CWE-918

Which versions are affected by CVE-2023-23684?

2 open source packages ship an affected version, including wp-graphql/wp-graphql. It affects 1 product.

PackageAffectedFixed in
wp-graphql/wp-graphql PackagistAll versions1.14.6
wp-graphql/wp-graphql PackagistAll versions1.14.6

Products include Wpengine Wpgraphql.

How do I fix CVE-2023-23684?

Upgrade wp-graphql/wp-graphql to 1.14.6 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2023-23684 being exploited?

There is no known exploitation of CVE-2023-23684 in the wild and no public exploit code.

Sources

Also known as GHSA-cfh4-7wq9-6pgg.

Is CVE-2023-23684 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free