{"answers":{"affected":"2 open source packages ship an affected version, including wp-graphql/wp-graphql. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-23684 in the wild and no public exploit code.","fix":"Upgrade wp-graphql/wp-graphql to 1.14.6 or later.","what":"CVE-2023-23684 is a medium-severity server-side request forgery vulnerability in WPGraphQL, published on 13 Nov 2023. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-23684 and fix it if it is affected.\n\nWhat it is: CVE-2023-23684 is a medium-severity server-side request forgery vulnerability in WPGraphQL, published on 13 Nov 2023. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-23684 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wp-graphql/wp-graphql (Packagist): affected all versions; fixed in 1.14.6\n- wp-graphql/wp-graphql (Packagist): affected all versions; fixed in 1.14.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-23684/ (Markdown: https://insights.sbomify.com/CVE-2023-23684/index.md)","id":"CVE-2023-23684","markdown":"https://insights.sbomify.com/CVE-2023-23684/index.md","name":"CVE-2023-23684","record":{"aliases":["GHSA-cfh4-7wq9-6pgg"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"high_privilege","summary":"An attacker can exploit a Server-Side Request Forgery vulnerability in the WPGraphQL WordPress plugin to access internal resources or bypass security controls.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Patchstack","cpe":[{"product":"wpgraphql","vendor":"wpengine"}],"cvss":{"score":4.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Server-Side Request Forgery (SSRF) vulnerability in WPGraphQL.This issue affects WPGraphQL: from n/a through 1.14.5.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress WPGraphQL Plugin \u003c= 1.14.5 is vulnerable to Server Side Request Forgery (SSRF)","id":"CVE-2023-23684","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"ssrf","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"WordPress Portfolio – WordPress Portfolio Plugin Plugin \u003c= 2.8.10 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-23685"},"packages":[{"ecosystem":"Packagist","fixed":["1.14.6"],"introduced":["0"],"last_affected":[],"package":"wp-graphql/wp-graphql","purl":null,"source":"GHSA-cfh4-7wq9-6pgg"},{"ecosystem":"Packagist","fixed":["1.14.6"],"introduced":["0"],"last_affected":[],"package":"wp-graphql/wp-graphql","purl":"pkg:composer/wp-graphql/wp-graphql","source":"GHSA-cfh4-7wq9-6pgg"}],"prev":{"headline":"WordPress White Label Branding for Elementor Page Builder Plugin \u003c= 1.0.2 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-23683"},"products":["WPGraphQL"],"published":"2023-11-13","related":[{"cvss_score":9.8,"headline":"Privilege escalation in n/a","id":"CVE-2019-9879","kev_date_added":null,"published":"2019-06-10"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2019-9880","kev_date_added":null,"published":"2019-06-10"},{"cvss_score":5.3,"headline":"WPGraphQL WooCommerce \u003c= 0.11.0 - Unauthenticated Coupon Codes Disclosure","id":"CVE-2022-1563","kev_date_added":null,"published":"2024-01-16"},{"cvss_score":5.3,"headline":"Missing authorization in n/a","id":"CVE-2019-9881","kev_date_added":null,"published":"2019-06-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2026-04-28","vendors":["WPGraphQL"]},"summary":"An attacker can exploit a Server-Side Request Forgery vulnerability in the WPGraphQL WordPress plugin to access internal resources or bypass security controls.","url":"https://insights.sbomify.com/CVE-2023-23684/"}