# CVE-2023-23684: WordPress WPGraphQL Plugin <= 1.14.5 is vulnerable to Server Side Request Forgery (SSRF)

> An attacker can exploit a Server-Side Request Forgery vulnerability in the WPGraphQL WordPress plugin to access internal resources or bypass security controls.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Nov 2023
- **Updated:** 28 Apr 2026
- **Also known as:** GHSA-cfh4-7wq9-6pgg

## What is CVE-2023-23684?

CVE-2023-23684 is a medium-severity server-side request forgery vulnerability in WPGraphQL, published on 13 Nov 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Server-Side Request Forgery (SSRF) vulnerability in WPGraphQL.This issue affects WPGraphQL: from n/a through 1.14.5.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-23684?

2 open source packages ship an affected version, including wp-graphql/wp-graphql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wp-graphql/wp-graphql` | Packagist | All versions | 1.14.6 |
| `wp-graphql/wp-graphql` | Packagist | All versions | 1.14.6 |

Products: Wpengine Wpgraphql.

## How do I fix CVE-2023-23684?

Upgrade wp-graphql/wp-graphql to 1.14.6 or later.

## Is CVE-2023-23684 being exploited?

There is no known exploitation of CVE-2023-23684 in the wild and no public exploit code.

## Other vulnerabilities in WPGraphQL

- [CVE-2019-9879](https://insights.sbomify.com/CVE-2019-9879/): Privilege escalation in n/a (critical 9.8)
- [CVE-2019-9880](https://insights.sbomify.com/CVE-2019-9880/): Information disclosure in n/a (critical 9.1)
- [CVE-2022-1563](https://insights.sbomify.com/CVE-2022-1563/): WPGraphQL WooCommerce <= 0.11.0 - Unauthenticated Coupon Codes Disclosure (medium 5.3)
- [CVE-2019-9881](https://insights.sbomify.com/CVE-2019-9881/): Missing authorization in n/a (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-23684 and fix it if it is affected.

What it is: CVE-2023-23684 is a medium-severity server-side request forgery vulnerability in WPGraphQL, published on 13 Nov 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-23684 in the wild and no public exploit code.

Affected packages and fixed versions:
- wp-graphql/wp-graphql (Packagist): affected all versions; fixed in 1.14.6
- wp-graphql/wp-graphql (Packagist): affected all versions; fixed in 1.14.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-23684/ (Markdown: https://insights.sbomify.com/CVE-2023-23684/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-23684
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-23684
- OSV: https://osv.dev/vulnerability/CVE-2023-23684

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-23684/
Summaries are generated and may contain mistakes; the official description above is the record.
