# CVE-2023-23752: Joomla! Improper Access Control

> Unauthorized attackers can access webservice endpoints in Joomla due to improper access checks, potentially reading or modifying data.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Yes, since 8 Jan 2024 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Feb 2023
- **Updated:** 26 Feb 2026
- **Also known as:** BIT-joomla-2023-23752, GHSA-jmc9-376w-885v

## What is CVE-2023-23752?

CVE-2023-23752 is a medium-severity missing authorization vulnerability in Joomla Joomla\!, published on 16 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Joomla! 4.0.0 through 4.2.7. An improper access check allows unauthorized access to webservice endpoints.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2023-23752?

1 open source package ship an affected version, including joomla. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joomla` | Bitnami | From 4.0.0 | 4.2.8 |

Products: Joomla Joomla\!.

## How do I fix CVE-2023-23752?

Upgrade joomla to 4.2.8 or later. US federal agencies must fix it by 29 Jan 2024.

## Is CVE-2023-23752 being exploited?

Yes. Attackers have exploited CVE-2023-23752 in the wild since at least 8 Jan 2024.

Public exploit code:

- Joomla! < 4.2.8 - Unauthenticated information disclosure (github_poc): https://github.com/Acceis/exploit-CVE-2023-23752
- Perform With Mass Exploiter In Joomla 4.2.8. (github_poc): https://github.com/Ap0dexMe0/CVE-2023-23752
- simple program for joomla CVE-2023-23752 scanner for pentesting and educational purpose (github_poc): https://github.com/z3n70/CVE-2023-23752
- Joomla 未授权访问漏洞 CVE-2023-23752 (github_poc): https://github.com/keyuan15/CVE-2023-23752
- Bulk scanner + get config from CVE-2023-23752 (github_poc): https://github.com/gibran-abdillah/CVE-2023-23752
- Poc for CVE-2023-23752 (github_poc): https://github.com/adhikara13/CVE-2023-23752

## Other vulnerabilities in Joomla Joomla\!

- [CVE-2016-10033](https://insights.sbomify.com/CVE-2016-10033/): PHPMailer Command Injection (critical 9.8, exploited in the wild)
- [CVE-2026-48902](https://insights.sbomify.com/CVE-2026-48902/): Joomla! Core - [20260518] - Transport encryption downgrade for password and username reset links (critical 9.8)
- [CVE-2025-25226](https://insights.sbomify.com/CVE-2025-25226/): [20250401] - Joomla Framework - SQL injection vulnerability in quoteNameStr method of Database package (critical 9.8)
- [CVE-2022-23795](https://insights.sbomify.com/CVE-2022-23795/): [20220303] - Core - User row are not bound to a authentication mechanism (critical 9.8)
- [CVE-2022-23797](https://insights.sbomify.com/CVE-2022-23797/): [20220305] - Core - Inadequate filtering on the selected Ids (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-23752 and fix it if it is affected.

What it is: CVE-2023-23752 is a medium-severity missing authorization vulnerability in Joomla Joomla\!, published on 16 Feb 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2023-23752 in the wild since at least 8 Jan 2024.

Affected packages and fixed versions:
- joomla (Bitnami): affected from 4.0.0; fixed in 4.2.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-23752/ (Markdown: https://insights.sbomify.com/CVE-2023-23752/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-23752
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-23752
- OSV: https://osv.dev/vulnerability/CVE-2023-23752

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-23752/
Summaries are generated and may contain mistakes; the official description above is the record.
