CVE-2023-23814 WordPress Calendar Event Multi View plugin <= 1.4.13 - Broken Access Control vulnerability

Low 3.8 Published Updated

Attackers can bypass access controls in the CP Multi View Event Calendar plugin to perform unauthorized actions.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-23814?

CVE-2023-23814 is a low-severity missing authorization vulnerability in CodePeople CP Multi View Event Calendar, published on 9 Dec 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Missing Authorization vulnerability in CodePeople CP Multi View Event Calendar allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects CP Multi View Event Calendar : from n/a through 1.4.13.

Weakness: CWE-862

Which versions are affected by CVE-2023-23814?

2 open source packages ship an affected version, including wordpress-multisite and wordpress.

PackageAffectedFixed in
wordpress-multisite BitnamiAll versions1.4.15
wordpress BitnamiAll versions1.4.15

How do I fix CVE-2023-23814?

Upgrade wordpress-multisite to 1.4.15 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-23814 being exploited?

There is no known exploitation of CVE-2023-23814 in the wild and no public exploit code.

Sources

Also known as BIT-wordpress-2023-23814, BIT-wordpress-multisite-2023-23814, GHSA-g8qh-57gx-75gj.

Is CVE-2023-23814 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free