{"answers":{"affected":"2 open source packages ship an affected version, including wordpress-multisite and wordpress.","exploited":"There is no known exploitation of CVE-2023-23814 in the wild and no public exploit code.","fix":"Upgrade wordpress-multisite to 1.4.15 or later.","what":"CVE-2023-23814 is a low-severity missing authorization vulnerability in CodePeople CP Multi View Event Calendar, published on 9 Dec 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-23814 and fix it if it is affected.\n\nWhat it is: CVE-2023-23814 is a low-severity missing authorization vulnerability in CodePeople CP Multi View Event Calendar, published on 9 Dec 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-23814 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress-multisite (Bitnami): affected all versions; fixed in 1.4.15\n- wordpress (Bitnami): affected all versions; fixed in 1.4.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-23814/ (Markdown: https://insights.sbomify.com/CVE-2023-23814/index.md)","id":"CVE-2023-23814","markdown":"https://insights.sbomify.com/CVE-2023-23814/index.md","name":"CVE-2023-23814","record":{"aliases":["BIT-wordpress-2023-23814","BIT-wordpress-multisite-2023-23814","GHSA-g8qh-57gx-75gj"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"high_privilege","summary":"Attackers can bypass access controls in the CP Multi View Event Calendar plugin to perform unauthorized actions.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Patchstack","cpe":[],"cvss":{"score":3.8,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Missing Authorization vulnerability in CodePeople CP Multi View Event Calendar  allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects CP Multi View Event Calendar : from n/a through 1.4.13.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress Calendar Event Multi View plugin \u003c= 1.4.13 - Broken Access Control vulnerability","id":"CVE-2023-23814","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"missing_authorization","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"WordPress Multi-column Tag Map Plugin \u003c= 17.0.24 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-23815"},"packages":[{"ecosystem":"Bitnami","fixed":["1.4.15"],"introduced":["0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2023-23814"},{"ecosystem":"Bitnami","fixed":["1.4.15"],"introduced":["0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2023-23814"}],"prev":{"headline":"WordPress My Calendar Plugin \u003c= 3.4.3 is vulnerable to Cross Site Request Forgery (CSRF)","id":"CVE-2023-23813"},"products":["CP Multi View Event Calendar"],"published":"2024-12-09","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-28","vendors":["CodePeople"]},"summary":"Attackers can bypass access controls in the CP Multi View Event Calendar plugin to perform unauthorized actions.","url":"https://insights.sbomify.com/CVE-2023-23814/"}